NetWorker: "Failed to open the lock file: Permission denied " error seen on running any command within nsr

Summary: Not able to use any NetWorker command-line utilities due to permission issues.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The mminfo command fails with the following error:
136611:mminfo: Failed to open the lock file: Permission denied
144502:nsrd: Unable to set user privileges based on user token for localadmin on <NW-Server-Name>: Failed to validate security token.
167325:mminfo: Unable to connect to media database server on host <NW-Server-Name>: Unable to set user privileges based on user token for localadmin on <NW-Server-Name>: Failed to validate security token.

nsrcapinfo, nsradmin, nsrlogin, nsrauthtrust, so on, are also affected.

Cause

.administrator.lck file does not have sufficient permission on the NetWorker server host.

Resolution

Changing permissions on the nsrlogin lock file at /nsr/tmp/sec/tokens

Windows:

  1. Navigate to /nsr/tmp/sec/tokens
  2. Locate file ".nsrlogin.localadmin.lck" (This is a hidden file, on Windows click view, then show hidden).
  3. Modify the file permission for local admin to have Full Control.

Linux:

  1. cd /nsr/tmp/sec/tokens
  2.  Type "ls -lat", so you can list all the hidden files and show permissions.
  3. Modify the file permissions to have Read, Write, and Execute permissions.
Article Properties
Article Number: 000220446
Article Type: Solution
Last Modified: 23 Feb 2024
Version:  2
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