Connectrix B-Serien: Kunne ikke legge til lisensnøkkel for å bytte med feilmeldingen «Kan ikke utføre lisensendringer»

Summary: Kan ikke legge til lisens på MX610s-svitsj ved hjelp av "licenseadd " kommando for FOS versjon 8.1.x. Kommandoene "License install -k" og "License -install " støttes ikke på FOS versjon 8.1.x. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Error:
Switch-A:admin licenseadd "W4ZfEaJftZaSJAJJQRff37KSKHRgJrFrEFPfQFH*****"
adding license-key [W4ZfEaJftZaSJAJJQRff37KSKHRgJrFrEFPfQFH*****]
failed to commit license changes

Cause

Kan ikke kjøre SupportSave og lisensinstallasjon på grunn av feil:
 "The switch does not have enough disk space to run full supportsave. Available Free disk space is 0 MB."
 
Switch-A:admin> supportsave
This command collects RASLOG, TRACE, supportShow, core file, FFDC data
and then transfer them to a FTP/SCP/SFTP server or a USB device.
This operation can take several minutes.
OK to proceed? (yes, y, no, n): [no] yes
Host IP or Host Name: 10.82.50.27
User Name: username
Password: ******
Protocol (ftp | scp | sftp): sftp
Remote Directory: /home/inti/brocade
Do you want to continue with CRA (Y/N) [N]:
The switch does not have enough disk space to run full supportsave. Available Free disk space is 0 MB.
Please run the following commands to release disk space and retry full supportsave
1. "supportsave -k" to transfer core files to remote location
2. "supportsave -R" to remove the core files in the switch
SupportSave failed.
Se etter kjernefiler som skal slettes fra kommandoen nedenfor:
Switch-A:admin> supportsave -R
No core or FFDC data files found!
SupportSave completed.

Resolution

Det er flere mulige måter å løse dette problemet på:
  • Løsning 1:
  1. Kjør kommandoen nedenfor for å bekrefte om rotkonto er aktivert.
 userconfig --show root
  1. Fjern rotkontoen ved hjelp av rotkontoen /var/log/esmd_lib.log Filer som kan ta mer flashminne
  1. Fang utdataene fra kommandoen nedenfor fra roten.
root> ls lR /var
I denne utdataene skal du se følgende:
/var/log:

-rw-r--r--   1 root     root      3113586 Oct 14 11:16 esmd_lib.log
-rw-r--r--   1 root     admin    14065977 Oct 13 05:17 esmd_lib.log.1
-rw-r--r--   1 root     admin    82593068 Oct  7 11:04 esmd_lib.log.2
-rw-r--r--   1 root     root     329366414 Sep  2 13:41 esmd_lib.log.3
  1. Utsted følgende kommandoer fra roten for å fjerne filene
rm /var/log/esmd_lib.log
rm /var/log/esmd_lib.log.1
rm /var/log/esmd_lib.log.2
Dette renser opp Flash-minne og lar supportsave som skal kjøres.
  1. Samle supportsave og installere lisens ved hjelp av licenseadd <key> Kommando etter å ha ryddet opp i flashminnet.
  2. Hvis rotkontoen er aktivert, kjører du kommandoen nedenfor som fjerner midlertidige og uønskede fastvarefiler.
df -k 
 
Hvis rotkontoen ikke er aktivert, kan det hende du ikke kan aktivere på grunn av minneproblem. Følg løsning 2 hvis rotkontoen er deaktivert.
Switch_A:admin> userconfig --show root
Account name: root*
Description: root
Enabled: No
Password Last Change Date: Unknown (UTC)
Password Expiration Date: Not Applicable (UTC)
Locked: No
Role: root
AD membership: 0-255
Home AD: 0
Day Time Access: N/A
Switch_A:admin> userconfig --change root -e yes
sqlite3_exec error: 10 disk I/O error
Failed to change user account attributes
  • Løsning 2:
  1. Ta sikkerhetskopi av konfigurasjonen og utfør Hareboot Under Vedlikeholdsvindu for å fjerne flashminneproblemet.
  2. Etter å ha utført HarebootSamle supportsave logger og prøver å installere lisensen ved hjelp av licenseadd <key> Kommandoen.
  • Løsning 3:
Hvis løsning 2 ikke tømmer flashminnet eller aktiverer rotkontoen, kontakter du svitsjleverandøren for å få mer hjelp før du bytter ut en svitsj.

Additional Information

Affected Products

Dell EMC Networking MX-G610s
Article Properties
Article Number: 000223916
Article Type: Solution
Last Modified: 10 May 2024
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.