Connectrix řady B: Přidání licenčního klíče do přepínače se nezdařilo a zobrazí se chyba "Failed to commit license changes"

Summary: Nelze přidat licenci k přepínači MX610s pomocí příkazu "licenseadd". " pro FOS verze 8.1.x. Příkazy "License install -k" a "License -install" " nejsou podporovány v systému FOS verze 8.1.x. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Chyba:
Switch-A:admin licenseadd "W4ZfEaJftZaSJAJJQRff37KSKHRgJrFrEFPfQFH*****"
adding license-key [W4ZfEaJftZaSJAJJQRff37KSKHRgJrFrEFPfQFH*****]
failed to commit license changes

Cause

Spuštění souboru supportsave a instalace licence se nezdařilo kvůli chybě:
 "The switch does not have enough disk space to run full supportsave. Available Free disk space is 0 MB."
 
Switch-A:admin> supportsave
This command collects RASLOG, TRACE, supportShow, core file, FFDC data
and then transfer them to a FTP/SCP/SFTP server or a USB device.
This operation can take several minutes.
OK to proceed? (yes, y, no, n): [no] yes
Host IP or Host Name: 10.82.50.27
User Name: username
Password: ******
Protocol (ftp | scp | sftp): sftp
Remote Directory: /home/inti/brocade
Do you want to continue with CRA (Y/N) [N]:
The switch does not have enough disk space to run full supportsave. Available Free disk space is 0 MB.
Please run the following commands to release disk space and retry full supportsave
1. "supportsave -k" to transfer core files to remote location
2. "supportsave -R" to remove the core files in the switch
SupportSave failed.
Níže uvedeným příkazem vyhledejte soubory jádra, které chcete odstranit:
Switch-A:admin> supportsave -R
No core or FFDC data files found!
SupportSave completed.

Resolution

Existuje několik možných způsobů, jak tento problém vyřešit:
  • Oprava 1:
  1. Spuštěním níže uvedeného příkazu ověřte, zda je povolen účet uživatele root.
 userconfig --show root
  1. Pomocí účtu uživatele root odstraňte /var/log/esmd_lib.log soubory, které mohou zabírat více paměti flash
  1. Zaznamenejte výstup následujícího příkazu z uživatele root.
root> ls lR /var
V tomto výstupu byste měli vidět následující:
/var/log:

-rw-r--r--   1 root     root      3113586 Oct 14 11:16 esmd_lib.log
-rw-r--r--   1 root     admin    14065977 Oct 13 05:17 esmd_lib.log.1
-rw-r--r--   1 root     admin    82593068 Oct  7 11:04 esmd_lib.log.2
-rw-r--r--   1 root     root     329366414 Sep  2 13:41 esmd_lib.log.3
  1. Chcete-li soubory odstranit, zadejte následující příkazy z kořenového adresáře
rm /var/log/esmd_lib.log
rm /var/log/esmd_lib.log.1
rm /var/log/esmd_lib.log.2
Tím se vyčistí paměť Flash a umožní supportsave které mají být spuštěny.
  1. Shromažďovat supportsave a nainstalujte licenci pomocí licenseadd <key> příkaz po vyčištění paměti flash.
  2. Pokud je účet root povolen, spusťte níže uvedený příkaz, který odstraní dočasné a nežádoucí soubory firmwaru.
df -k 
 
Pokud účet uživatele root není povolen, je možné, že jej nebudete moci povolit kvůli problému s pamětí. Pokud je účet root zakázán, postupujte podle opravy 2.
Switch_A:admin> userconfig --show root
Account name: root*
Description: root
Enabled: No
Password Last Change Date: Unknown (UTC)
Password Expiration Date: Not Applicable (UTC)
Locked: No
Role: root
AD membership: 0-255
Home AD: 0
Day Time Access: N/A
Switch_A:admin> userconfig --change root -e yes
sqlite3_exec error: 10 disk I/O error
Failed to change user account attributes
  • Oprava 2:
  1. Proveďte zálohu konfigurace a Hareboot v okně údržby k odstranění problému s pamětí flash.
  2. Po provedení HarebootShromažďovat supportsave protokoly, a zkuste nainstalovat licenci pomocí licenseadd <key> .
  • Oprava 3:
Pokud oprava 2 nevymaže paměť flash nebo nepovolí účet root, požádejte před výměnou přepínače o další pomoc dodavatele přepínače.

Additional Information

Referenční článek znalostní databáze : https://www.dell.com/support/kbdoc/en-in/000064137

Affected Products

Dell EMC Networking MX-G610s
Article Properties
Article Number: 000223916
Article Type: Solution
Last Modified: 10 May 2024
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.