Connectrix B-Series: Fail to Add License Key to Switch with Error "Failed to commit license changes"
Summary:
Unable to add license to MX610s switch using "licenseadd " command for FOS version 8.1.x. The commands "License install -k" and "License -install " are not supported on FOS
version 8.1.x.
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Symptoms
Error:
Switch-A:admin licenseadd "W4ZfEaJftZaSJAJJQRff37KSKHRgJrFrEFPfQFH*****" adding license-key [W4ZfEaJftZaSJAJJQRff37KSKHRgJrFrEFPfQFH*****] failed to commit license changes
Cause
Fails to run Supportsave and license install due to error:
"The switch does not have enough disk space to run full supportsave. Available Free disk space is 0 MB."
Switch-A:admin> supportsave This command collects RASLOG, TRACE, supportShow, core file, FFDC data and then transfer them to a FTP/SCP/SFTP server or a USB device. This operation can take several minutes. OK to proceed? (yes, y, no, n): [no] yes Host IP or Host Name: 10.82.50.27 User Name: username Password: ****** Protocol (ftp | scp | sftp): sftp Remote Directory: /home/inti/brocade Do you want to continue with CRA (Y/N) [N]: The switch does not have enough disk space to run full supportsave. Available Free disk space is 0 MB. Please run the following commands to release disk space and retry full supportsave 1. "supportsave -k" to transfer core files to remote location 2. "supportsave -R" to remove the core files in the switch SupportSave failed.Look for core files to be deleted from the below command:
Switch-A:admin> supportsave -R No core or FFDC data files found! SupportSave completed.
Resolution
There are several possible ways to address this issue:
- Fix 1:
- Run the below command to confirm if root account is enabled.
userconfig --show root
- Using root account, remove
/var/log/esmd_lib.logfiles which may be taking more flash memory
- Capture the output of the below command from root.
root> ls lR /var
In this output, you should see the following:
/var/log: -rw-r--r-- 1 root root 3113586 Oct 14 11:16 esmd_lib.log -rw-r--r-- 1 root admin 14065977 Oct 13 05:17 esmd_lib.log.1 -rw-r--r-- 1 root admin 82593068 Oct 7 11:04 esmd_lib.log.2 -rw-r--r-- 1 root root 329366414 Sep 2 13:41 esmd_lib.log.3
- Issue the following commands from root to remove the files
rm /var/log/esmd_lib.log rm /var/log/esmd_lib.log.1 rm /var/log/esmd_lib.log.2
This cleans up Flash Memory and allows the
supportsave to be run.
- Collect
supportsaveand install license usinglicenseadd <key>command after cleaning up flash memory. - If the root account is enabled, run the below command which removes temp and unwanted firmware files.
df -k
If the root account is not enabled, you may be unable to enable due to memory issue. Follow fix 2 if the root account is disabled.
Switch_A:admin> userconfig --show root Account name: root* Description: root Enabled: No Password Last Change Date: Unknown (UTC) Password Expiration Date: Not Applicable (UTC) Locked: No Role: root AD membership: 0-255 Home AD: 0 Day Time Access: N/A
Switch_A:admin> userconfig --change root -e yes sqlite3_exec error: 10 disk I/O error Failed to change user account attributes
- Fix 2:
- Take backup of configuration and perform
Harebootunder maintenance window to clear flash memory issue. - After performing
Hareboot, collectsupportsavelogs and try to install the license usinglicenseadd <key>command.
- Fix 3:
If Fix 2 fails to clear flash memory or enable root account, engage the Switch vendor for further assistance prior to performing a switch replacement.
Affected Products
Dell EMC Networking MX-G610sArticle Properties
Article Number: 000223916
Article Type: Solution
Last Modified: 10 May 2024
Version: 2
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