APEX Backup Services: InSync Client Not Backing Up Folder While Configured in the InSync Profile

Summary: APEX Backup Services: InSync Client is not backing up folder while configured by the Admin in the InSync profile.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Discrepancy was found between the data selected in the profile to be backed up and the data which was backed up.

Folders are not excluded in the Druva Client exclusion list.

Cause

The end user is syncing these folders with the Microsoft OneDrive Client. 

When you enable the sync and backup of your folders with Microsoft OneDrive Client, the windows folder path of these folders changes to, for example c:\users\\onedrive\Documents. See the Microsoft article: My "documents" folder is linked to one drive. How to redirect it to its normal location This hyperlink is taking you to a website outside of Dell Technologies. for more information

User has excluded OneDrive folder path from the Global Exclusions of the profile. As exclusions take preference over inclusions, the folders backed up by OneDrive are being excluded. 

If we check the inSync.cfg file of the end user (Admin Console > Users > click the User in use > click 3 dots and download debug logs), notice that the affected folders show the folder path under OneDrive.

Resolution

Fix:
  • Disable sync and backup of these folders from OneDrive
Or
  • Disable the Global Exclusions for OneDrive
Note: By disabling Global Exclusions, any files or folders that are not local to the device and are located in OneDrive, are not backed up, and generate errors in each backup.

Additional Information

Why are we able to see these folders in the snapshots, even if excluded? 
  • Admin has configured the profile to backup the affected folders
  • InSync shows the configured folders in the backup
  • Due to the Global Exclusions excluding these folders through the OneDrive path, they are not being scanned, thus the InSync client does not display them.
  • Any data that was previously backed up before these folders were added to OneDrive, continues to show up in the backup snapshot for reference
  • New data is not being backed up

Affected Products

PowerProtect Backup Services
Article Properties
Article Number: 000224340
Article Type: Solution
Last Modified: 24 Apr 2024
Version:  1
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