VxRail: O agente vSphere HA não pode ser instalado ou configurado falha com o erro: Senha rejeitada para o usuário vpxuser

Summary: VxRail: o agente vSphere HA não pode ser instalado ou configurado.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

O nó não está disponível no vCenter.
Erros no vCenter para ESXi:
Cannot complete login due to an incorrect username or password
vSphere HA agent cannot be installed or configured
O cliente tinha revertido o vCenter devido a um problema ao tentar atualizar alguns nós no cluster. Os nós e as VMs já não são geridos pelo vCenter.
VXR014030 ALARM Check vSphere HA host status
Vsphere HA host status
Cannot synchronize host …………….

  Imagem do erro VXR014030 ALARME Verificar o estado do anfitrião vSphere HA
hostd.log
Rejected password for user vpxuser from XXX.XX.XX.XX (ip address) 
Imagem de erro com senha rejeitada para o usuário vpxuser de XXX.XX.XX.XX (endereço ip)
As VMs no nó ainda estão em execução. A integridade do vSAN da CLI reportou todos os testes no verde.
 esxcli vsan health cluster list
 
 
 

Cause

Este problema ocorre quando a palavra-passe em cache para vpxuser está incorreta no anfitrião ou a sua conta expirou no vCenter Server.
Esse hiperlink direcionará você para um site fora da Dell Technologies.
https://knowledge.broadcom.com/external/article?legacyId=2097171O vpxuser é um utilizador gerado no ESXi pelo vCenter assim que o nó é adicionado e religado ao vCenter.

Resolution

Para resolver esse problema, desconecte e conecte o host em vez de usar a "etapa de remoção do inventário" mencionada na KB do VMware acima.

Observação: No KB2097171, inclui a remoção do nó do inventário. A remoção do nó do inventário do vCenter é uma tarefa mais invasiva em comparação com a opção de desligar e voltar a ligar.
Em algumas situações, o cliente pode ter VMs ainda em execução no nó. Estas VMs podem não conseguir ser migradas ou registadas noutro nó devido ao estado ESXi não gerido.
Quando um anfitrião é removido do inventário, é completamente removido da gestão do vCenter e da participação vSAN. Antes de o remover, todas as VMs têm de estar desligadas. Quando o nó estiver fora do vCenter, as VMs têm de ser registadas num novo nó para serem ligadas. Por comparação, quando um anfitrião é desligado do vCenter, continua a participar no vSAN. Todas as VMs que estão no nó continuam a ser executadas sem problemas, mesmo que o anfitrião esteja desligado. 

Nota: Ao desligar um anfitrião gerido, suspende temporariamente todas as atividades de monitorização realizadas pelo vCenter Server. O anfitrião gerido e as máquinas virtuais associadas permanecem no inventário do vCenter Server. Esse hiperlink direcionará você para um site fora da Dell Technologies. https://docs.vmware.com/en/VMware-vSphere/7.0/com.vmware.vsphere.vcenterhost.doc/GUID-DE06875C-CB8C-442E-AC1D-24BFFA3F6705.htmlSe o nó não puder ser reconectado novamente devido a um problema de serviço adicional, é necessário desligar todas as VMs e reiniciá-lo para tentar reconectar. 


Etapas: 
  • Desligue o nó do vCenter https://docs.vmware.com/en/VMware-vSphere/7.0/com.vmware.vsphere.vcenterhost.doc/GUID-DE06875C-CB8C-442E-AC1D-24BFFA3F6705.htmlEsse hiperlink direcionará você para um site fora da Dell Technologies.
  • Abra uma sessão SSH no nó afetado:
  • Pare o serviço abaixo: (É necessário que este serviço seja interrompido antes de iniciar a tarefa de religação) 
    /etc/init.d/vpxa stop
  • Remover a conta:
    esxcli system account remove -i vpxuser
  • Confirme se a conta não está presente: 
    esxcli system account list
  • Volte para a interface do usuário do vCenter e conecte o host (haverá alguns erros em segundo plano indicando erros de usuário e senha, basta continuar com o assistente).
  • Conclua o assistente e o nó deve ser novamente gerenciável a partir do vCenter.
 

Affected Products

VMware ESXi 6.7.X, VMware ESXi 7.x, VMware vCenter Server
Article Properties
Article Number: 000225410
Article Type: Solution
Last Modified: 28 May 2024
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.