Unisphere for PowerMax not accessible due to REST API issue Too many open files

Summary: Unisphere for PowerMax is not accessible.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • REST API calls were checked as per - Unisphere for PowerMax installation guide . All criteria were met. 
  • Re-image of containers did not resolve the issue.
  • Reboot of management containers resolves the issue for a few days. 
  • All services were up and running.
  • Errors in run.log:
ERROR [em.spa.SPA] (EJB default - 13) com.emc.em.spa.datamanager.datalistener.RTCListener.Exception in opening DCF listen port (8089) in JVM (0):Too many open files
  • Errors in symapi.log:
04/03/2024 00:21:34.858 19033 27 EMC:UNIVMAX emcSymDBLoad pdsDbOpen() failed [/var/symapi/db/symapi_db.bin] ([PDS/File] Error opening file [Errno: 24 - Too many open files])

Cause

It was discovered that the external script being used to run and control the RESTAPI calls was not closing the HTTPS connection after each RESTAPI call.
Here 10.x.y.z is the REST API client, but it does not appear to be closing the HTTPS connection to Unisphere DMF IP 172.18.64.7:

java 19033 19951 root 3835u IPv6 6326647 0t0 TCP 172.18.64.7:pcsync-https->10.x.y.z:52042 (ESTABLISHED)

Resolution

It was discovered that the external script being used to run and control the RESTAPI calls was not closing the HTTPS connection after each RESTAPI call.

The external script was adjusted to close the HTTPS connection after each RESTAPI call and the issue was resolved.

Additional Information

For "Too many open files,” look in LSOF.txt (LiSt of Open Files):

This file can be found in EMC Grabs under the Host folder.

REST API client IP can be found in:

Unisphere-> Support > Actions -> Managed server resources 

Affected Products

Unisphere for PowerMax
Article Properties
Article Number: 000225588
Article Type: Solution
Last Modified: 20 Jan 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.