MAC Address Pass-through Does Not Work on Dell Pro Thunderbolt Dock
Summary: Learn what to do if a Dell Pro Thunderbolt Dock’s MAC address pass-through does not work.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
A Dell Pro Thunderbolt Dock may not use the MAC address pass-through when IT policy has locked the computer MAC address on the network. When this happens, the dock LAN does not use the computer’s MAC address. It uses the dock’s MAC address, instead.
Affected Platforms:
Dell 14 Premium DA14250Dell Pro 13 Plus PB13250Dell Pro 13 Premium PA13250Dell Pro 14 PC14250Dell Pro 14 Plus PB14250Dell Pro 14 Premium PA14250Dell Pro 16 PC16250Dell Pro 16 Plus PB16250Dell Pro Max 14 MC14250Dell Pro Max 14 Premium MA14250Dell Pro Max 16 MC16250Dell Pro Max 16 Plus MB16250Dell Pro Max 16 Premium MA16250Dell Pro Max 18 Plus MB18250Dell Pro Rugged 10 Tablet RA00260Dell Pro Rugged 12 Tablet RA02260- XPS 13 9350
Affected Docks:
Dell Pro Thunderbolt 4 Dock WD25TB4Dell Pro Thunderbolt 4 Smart Dock SD25TB4Dell Pro Thunderbolt 5 Dock WD25TB5Dell Pro Thunderbolt 5 Smart Dock SD25TB5
Cause
The MAC address is obtained from the Intel Management Engine, but the computer’s MAC address is erased from the Intel Management Engine. This causes the MAC address pass-through from the dock to fail.
Resolution
The MAC address pass-through can be corrected from either the BIOS Setup or by an IT administrator from Dell Command Configure. Select the appropriate option for more information.
BIOS Setup
- Restart the Dell computer.
- Watch for the Dell logo to appear on the screen. Once it appears, press the F2 key multiple times (do not just hold the key down).
- Continue pressing F2 until a message is seen that indicates entering System Setup or BIOS.
- Use the arrow keys to go to the Pre-boot Behavior section.
- Locate MAC Address Pass-Through and change the setting from System Unique MAC Address to Disable.
- Go to the Apply changes & Exit tab. Select Save and Exit to apply the changes and restart the computer.
- Repeat Steps 1 through 3 to enter the BIOS setup again.
- Use the arrow keys to go to the Pre-boot Behavior section.
- Locate MAC Address Pass-Through and change the setting from Disable to System Unique MAC Address.
- Go to the Apply changes & Exit tab. Select Save and Exit to apply the changes and restart the computer.
- Confirm if the LAN device MAC address is the platform pass-through MAC address or not. To do this, click the Start menu, search for
cmd, and then open Command Prompt. - Type
ipconfig /alland then press Enter. Next, check the MAC address that is in the Physical Address field to confirm if the MAC address pass-through is working.
Dell Command Configure
- Download Dell Command Configure from Support for Dell Command.
- Run the installer, selecting the default values for the installation path and configuration.
- Click the Start menu, search for
PowerShell, right-click Windows PowerShell, and then select Run as administrator. - Type
cd ‘C:\Program Files (x86)\Dell\Command Configure\X86_64’and then press Enter. - Type
.\cctk.exe --MacAddrPassThru=Disabledand then press Enter. - Confirm that PowerShell returns output that states
MacAddrPassThru=Disabled. - Restart the Dell computer and enter the operating system.
- Repeat Step 3 to run PowerShell as administrator.
- Type
cd ‘C:\Program Files (x86)\Dell\Command Configure\X86_64’and then press Enter. - Type
.\cctk.exe --MacAddrPassThru= SystemUniqueand then press Enter. - Confirm that PowerShell returns output that states
MacAddrPassThru= SystemUnique. - Restart the Dell computer and enter the operating system.
- Confirm if the LAN device MAC address is the platform pass-through MAC address or not. To do this, click the Start menu, search for
cmd, right-click Command Prompt, and then select Run as Administrator. - Type
ipconfig /alland then press Enter. Next, check the MAC address that is in the Physical Address field to confirm if the MAC address pass-through is working.
Affected Products
Dell 14 Premium DA14250, Dell Pro Max 14 Premium MA14250, Dell Pro Max 16 Premium MA16250, Dell Pro Max 16 Plus MB16250, Dell Pro Max 18 Plus MB18250, Dell Pro Max 14 MC14250, Dell Pro Max 16 MC16250, Dell Pro 13 Premium PA13250
, Dell Pro 14 Premium PA14250, Dell Pro 13 Plus PB13250, Dell Pro 14 Plus PB14250, Dell Pro 16 Plus PB16250, Dell Pro 14 PC14250, Dell Pro 16 PC16250, Dell Pro Rugged 10 Tablet RA00260, Dell Pro Rugged 12 Tablet RA02260, Dell Pro Thunderbolt 4 Smart Dock SD25TB4, Dell Pro Thunderbolt 5 Smart Dock SD25TB5, Dell Pro Thunderbolt 4 Dock WD25TB4, Dell Pro Thunderbolt 5 Dock WD25TB5, XPS 13 9350
...
Article Properties
Article Number: 000386163
Article Type: Solution
Last Modified: 25 Nov 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.