PowerStore: Unable to connect over IPMI/SOL - Error activating SOL payload: Unspecified error

Summary: Unable to activate the SOL connection over IPMI due to "Error activating SOL payload: Unspecified error"

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

While connected to a node Ethernet service port via Serial Over LAN (SOL) using IPMItool the connection may become unresponsive. This may be observed during a node reboot.  After a period of time you receive an error:
ipmitool -I lanplus - C 3 -H 128.221.1.252 -U console -P <service_tag> sol activate
Error activating SOL payload: Unspecified error
 

Cause

This happens when the connection drops but remains active. For IPMI/SOL, only one single connection to the same device is possible.

Resolution

You must manually end the SOL session (deactivate) and activate it once more:
ipmitool -I lanplus - C 3 -H 128.221.1.252 -U console -P <service_tag> sol deactivate
  
Activate the SOL session again with: 
ipmitool -I lanplus - C 3 -H 128.221.1.252 -U console -P <service_tag> sol activate
[SOL Session operational.  Use ~? for help]

Affected Products

PowerStore 1000X, PowerStore 1000T, PowerStore 3000X, PowerStore 5000X, PowerStore 5000T, PowerStore 7000T, PowerStore 9000X, PowerStore 9000T
Article Properties
Article Number: 000126366
Article Type: Solution
Last Modified: 21 Feb 2021
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.