PowerFlex: Unable to run ScaleIO Command. Error: MDM failed command
Summary: Unable to run ScaleIO command, error: "MDM failed command. Status: Invalid session Login and try again."
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Symptoms
When trying to run a command from Primary Metadata Manager (MDM), ScaleIO commands fail with an invalid session:
# scli --mdm_ip --login --username admin Enter password: Logged in. User role is Administrator. System ID is XXXXXXXXX # scli --mdm_ip --query_all_volumes Error: MDM failed command. Status: Invalid session. Please login and try again.
Cause
The issue causing the MDM to refuse connections is that the CallHome user "Monitor" is logging in again every ten minutes and does not log out. This results in user login sessions accumulating and filling the sessions table before the hard timeout can kick them.
Resolution
Remove (or comment) the following two lines in mdm/cfg/conf.txt, on both MDMs:
user_session_hard_timeout_secs=86400 user_session_timeout_secs=28800 Stop CallHome service temporarily
/opt/emc/scaleio/callhome/bin/delete_service.sh
Restart the MDM service:
kill
Wait for 10 minutes and then try to issue scli commands after logging in and Start call-home service again.
./opt/emc/scaleio/callhome/bin/create_service.sh
Additional Information
The error can also occur if the ScaleIO CLI session times out.
Affected Products
PowerFlex SoftwareProducts
PowerFlex SoftwareArticle Properties
Article Number: 000065938
Article Type: Solution
Last Modified: 19 Sept 2025
Version: 5
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