RecoverPoint: Replication process restarts

Summary: Replication process restarts

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

 

Replication process restarts
CLI logs will show the following event

            Time: <Day> <Date> <Customer Time>
            Topic: RPA
            Scope: NORMAL
            Level: ERROR & CLEAR
            Event ID: 10207
            Cluster: <Cluster Name>
            Global links: None
            RPAs: <RPA ID>
            Summary: Internal replication process has been restarted
            Service Request info: N/A

From storage logs:
Oct 21 05:05:57 localhost kernel: [14472039.329610] #0 - sll_map_pages: unable to map user pages: r=226 cur_num_pages=227 data_length=926208 rw=2             
Oct 21 05:05:57 localhost kernel: [14472039.329616] #0 - sll_dispatch_commands: sll_map_pages failed             
Oct 21 05:05:57 localhost kernel: [14472039.329620] #0 - sll_ioctl_do_generate_io: sll_dispatch_cmd failed in map_pages (res_dispatch = 2)

Cause

Transient situation around mapping user pages to kernel memory where processes access invalid memory, which leads to a segmentation fault.

Resolution

Workaround:

Increase the value of t_scsiInitiatorMaxMapPagesFailures from 2  to 5 and reboot the RPAs.


Resolution:

Dell EMC engineering is currently investigating this issue. A permanent fix is still in progress. Contact the Dell EMC Customer Support Center or your service representative for assistance and reference this solution ID.

Additional Information

Affected Products

RecoverPoint

Products

RecoverPoint, RecoverPoint CL, RecoverPoint EX, RecoverPoint SE
Article Properties
Article Number: 000167705
Article Type: Solution
Last Modified: 23 Sept 2024
Version:  4
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