PowerProtect: VM Direct Protection Engine fails to upgrade due
Summary: PowerProtect Data Manager (PPDM) VM Direct Protection Engine fails to upgrade causing remaining components to also fail to upgrade. PowerProtect Data Manager (PPDM): VM Direct Protection Engine fails to upgrade due to error message "VM found to have no ExtensionKey, but expected 'com.emc.vproxy.visd'" ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
While upgrading PowerProtect Data Manager from version 19.14 to 19.15, after core services are upgraded, the next step is to upgrade VM Direct Protection Engines.
The job responsible for VM Direct Protection Engine upgrade may fail with error messages similar to the following:
The job responsible for VM Direct Protection Engine upgrade may fail with error messages similar to the following:
Failed to complete the software update. UPG0037 - VM Direct Protection Engines update failed, Unable to update protection engine 'HostName/IPAddress' - AutoUpgrade request unsuccessful. Unable to AutoUpgrade vProxy. Unable to deploy vProxy HostName/IPAddress. Unable to deploy VM. Unable to delete the vProxy 'Hostname/IPAddress' from the vCenter server. Found VM with Moref 'VirtualMachine:MorefNumber' but it is not managed by our component. This can be due to a misconfiguration. VM found to have no ExtensionKey, but expected 'com.emc.vproxy.visd'. Remediation: Contact Dell Customer Support.
Cause
This happens when at some point of time a virtual machine got unregistered from VMware vCenter and then got registered again. As a result ExtensionKey assigned to virtual machine is not applicable anymore.
Resolution
To resolve this issue, delete virtual machine (VM Direct Protection Engine) from VMware vCenter and redeploy using PowerProtect Data Manager User Interface.
More information about deploying and or redeploying VM Direct Protection Engine can be found in the PowerProtect Data Manager Virtual Machine User Guide.
After VM Direct Protection Engine has been redeployed, restart PowerProtect Data Manager upgrade process.
More information about deploying and or redeploying VM Direct Protection Engine can be found in the PowerProtect Data Manager Virtual Machine User Guide.
After VM Direct Protection Engine has been redeployed, restart PowerProtect Data Manager upgrade process.
Affected Products
PowerProtect Data Manager Appliance, PowerProtect Data Manager, PowerProtect Data Manager Essentials, PowerProtect Data Manager SoftwareArticle Properties
Article Number: 000220104
Article Type: Solution
Last Modified: 02 Sept 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.