PowerEdge: Various servers fail due to BIOS "In-band Management" setting disabling IPMI

Summary: Various Dell enterprise products behave unexpectedly if IPMI is intentionally disabled from communicating between the operating system and iDRAC. This can be done by disabling the "In-band Management Interface" setting in BIOS System Security settings. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Various Dell enterprise software products rely on communication between iDRAC and the operating system's IPMI driver. The following are popular Dell products but this is not an exhaustive list:

  • Dell Update Packages (DUP): Requires IPMI to pass firmware payloads to the iDRAC for iDRAC to apply at reboot
  • Dell OpenManage Server Administrator (OMSA): Requires IPMI for most component monitoring managed by iDRAC such as fans, power, so forth
  • iDRAC Tools: Racadm and ipmitool require IPMI for local iDRAC communication
  • iDRAC Service Module (iSM): Requires IPMI to establish trusted high-speed communications with iDRAC over the USB network device created
  • Dell System Update (DSU): DSU's underlying Inventory Collector relies on IPMI to detect certain components and firmware versions and must apply the applicable DUP
When IPMI is disabled on Windows usually a warning event is logged in the Windows System event log. When IPMI is disabled on Linux, the following error is seen:
Could not open device at /dev/ipmi0 or /dev/ipmi/0 or /dev/ipmidev/0 

Cause

One possible reason for IPMI to fail causing Dell product to also fail is the intentional disabling of the "In-band Management Interface" settings found in BIOS settings under "System Security". This completely hides the IPMI bus to iDRAC from the operating system.

Another reason could be that the IPMI driver has been disabled in Windows or the IPMI module in Linux has been stopped.

Resolution

The native IPMI driver of Windows must be enabled and loaded. This can be confirmed:

  1. Open Device Manager then select View > Show hidden devices
  2. Under System devices section open Microsoft Generic IPMI Compliant Device
  3. Verify Device status has no errors

For Linux verify that IPMI modules are active and loaded with "lsmod | grep -i ipmi", especially the ipmi_si module.

Also verify in BIOS settings that System Security > In-band Management Interface is enabled

Affected Products

Dell System Update, OpenManage Server Administrator, Update Packages, iDRAC Service Module, OEMR R440, OEMR R450, OEMR R540, OEMR R550, OEMR R640, OEMR R6415, OEMR R650, OEMR R650xs, OEMR R6515, OEMR R6525, OEMR R660, OEMR R660xs, OEMR R6615 , OEMR R6625, OEMR R740, OEMR R740xd, OEMR R740xd2, OEMR R7415, OEMR R7425, OEMR R750, OEMR R750xa, OEMR R750xs, OEMR R7515, OEMR R7525, OEMR R760, OEMR R760xa, OEMR R760XD2, OEMR R760xs, OEMR R7615, OEMR R7625, OEMR R840, OEMR R860, OEMR R940, OEMR R940xa, OEMR R960, PowerEdge R440, PowerEdge R450, PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960 ...
Article Properties
Article Number: 000247770
Article Type: Solution
Last Modified: 10 Jul 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.