Data Protection Advisor (DPA) - LDAP user unable to log into DPA
Summary: LDAP user unable to log into DPA
Symptoms
Entering LDAP username and password in DPA Gui does not produce any action. And no popup error is generated.
It was observed that if one types in an incorrect username or password, DPA provides message that incorrect username or password has been entered.
After setting server to log Configuration in DEBUG and reproducing the issue, the following error is captured in debug server logs:
2020-04-09 19:54:15,865 DEBUG [com.emc.apollo.login.LDAPAuthenticationStrategy] (http-/0.0.0.0:9002-5) LDAP authentication Error: [LDAP: error code 49 - 80090308: LdapErr: DSID-0C090442, comment: AcceptSecurityContext error, data 775, v3839 ]
Cause
Further investigation on the LDAP error code reveals that the user account is locked out:
49 775 1909 ERROR_ACCOUNT_LOCKED_OUT
Resolution
Contact DELL Technical Support for further details.