SupportAssist OS Recovery Assistant Displays an Error During the SupportAssist OS Recovery Process
Summary: Learn about SupportAssist OS recovery Assistant displaying an error message that Dell Digital Delivery (DDD) is not installed during the SupportAssist OS recovery process.
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Symptoms
Affected Products:
- SupportAssist OS Recovery
Affected Operating Systems:
- Windows 10 x64 of 20H1, 20H2, 21H2, 22H2
- Windows 11 x64 22H2, 23H2, 24H2, 25H2
After SupportAssist OS Recovery deployment:
- SupportAssist OS Recovery Assistant application launches automatically. This application launches DDD.
- Since DDD has been retired and removed from installation during SupportAssist OS Recovery deployment, this option in this SupportAssist OS Recovery Assistant application user interface displays the error Dell Digital Delivery not installed!
Cause
The DDD application has reached end-of-life. It is being replaced with Dell Purchase or Dell Optimizer applications. As a result, the Dell SupportAssist OS Recovery application has stopped installing DDD during the Dell SupportAssist OS recovery process.
Resolution
Dell Technologies recommends installing Dell Optimizer or the Dell Purchase application by referring to the Dell knowledge base article Dell Digital Delivery and Alienware Digital Delivery End of Life Announcement.
Affected Products
SupportAssist OS RecoveryArticle Properties
Article Number: 000400381
Article Type: Solution
Last Modified: 05 Dec 2025
Version: 1
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