Data Protection Advisor (DPA): Networker data collection requests fail with “error running nsradmin against server”

Summary: Networker data collection requests fail with “error running nsradmin against server”

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



All data collection requests for NetWorker failing with  error running nsradmin against server 


Observations from agent in debug:
DBG1    48066.48109    20200402:164006      com.base.runcmd - csystemopen(): cmd to run is: '/usr/sbin/nsradmin'

DBG1    48066.48109    20200402:164006      com.base.runcmd - csystemopen(): argument 0 is nsradmin
DBG1    48066.48109    20200402:164006      com.base.runcmd - csystemopen(): argument 1 is -s
DBG1    48066.48109    20200402:164006      com.base.runcmd - csystemopen(): argument 2 is nwserv.domain.com
DBG1    48066.48109    20200402:164006      com.base.runcmd - csystemopen(): input is . type: NSR
show type; version; hostname
print
quit
DBG2    48066.48109    20200402:164007      com.base.runcmd - csystemreadline(): select took 1.00503 seconds. 3598.99 seconds left
DBG2    48066.48109    20200402:164008      com.base.runcmd - csystemreadline(): select took 0.995401 seconds. 3598 seconds left
DBG2    48066.48109    20200402:164008        com.base.i18n - convertToUTF8Data(): convdata->conv is NULL
DBG1    48066.48109    20200402:164008      com.base.runcmd - csystemreadline(): failed to write to child
DBG1    48066.48109    20200402:164008      com.base.runcmd - csystemclose(): child exited with status 1


When running the command manually on Networker directly, the command runs correctly/without a problem.

When checking status on Networker, the following message appears:
Test # 9 - Checking for unmounted devices ... 144502:nsrd: Unable to set user privileges based on user token for root on nwserv.domain.com: Security token has expired.

Cause

This is a NetWorker authentication issue.

Resolution

Refer to the following KB article for Networker to resolve the issue with authentication:
https://support.emc.com/kb/487486

Please contact DELL Technical Support for further information.

Affected Products

Data Protection Advisor

Products

Data Protection Advisor
Article Properties
Article Number: 000173604
Article Type: Solution
Last Modified: 25 Apr 2025
Version:  3
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