Unipshere for PowerMax: Performance data not being collected

Summary: Unisphere performance data on Windows hosts will not collect data due to a network or Windows issue.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Unisphere performance data on Windows host will not collect data, ports 8088 and 8089 will not stay listening from netstat.

The storsptd.log and the storstpd daemon could not send the processed performance data file DCF to the Postgres database via the default port 8088 and port 8089
            Snippet from the storstpd.log:
               <Error> [3372 dcfSpaSender] Dec-02 13:02:23.316 pdsIpcClientConnInit #1813 : Unable to establish client connection [pdsSockSocket()/pdsSockConnect() failed], nRc= 700004019
               <Error> [3372 dcfSpaSender] Dec-02 13:02:23.316 : [sendFile()] TID: 740 SID: 000497600171 unable to connect to server: 10.63.29.73 on port: 8088.
               <Warn > [3372 dcfSpaSender] Dec-02 13:02:23.316 : [dcfSpaSender()] TID: 740 error processing file: 20221201_0205_000497600171_I.dcf.gz.
               <Error> [3372 SpaRtPackager] Dec-02 13:02:23.504 pdsSockConnect #2494 : connect() failed: [fd=1500] [WSA code: 10061 - No connection could be made because the target machine actively refused it.]
               <Error> [3372 SpaRtPackager] Dec-02 13:02:23.504 pdsIpcClientConnInit #1813 : Unable to establish client connection [pdsSockSocket()/pdsSockConnect() failed], nRc= 700004019


Postgress database logs show database system was interrupted and regularly starting up:
            2022-12-01 12:41:15 GMT:127.0.0.1(58618):wlp@wlp:[14116]:LOG: could not receive data from client: An existing connection was forcibly closed by the remote host.
            2022-12-01 12:41:15 GMT:127.0.0.1(52768):spa@spa:[1424]:LOG: could not receive data from client: An existing connection was forcibly closed by the remote host.
            2022-12-01 12:41:15 GMT:127.0.0.1(55006):spa@spa:[13544]:LOG: could not receive data from client: An existing connection was forcibly closed by the remote host.

Confirmation was made that there were no errors logged in the SMAS & RUN logs to show that the required ports are in use by other processes\applications:
            Eg, Error [em.spa.SPA] (EJB default - 4) com.emc.em.spa.datamanager.datalistener.RTCListener.Exception in opening DCF listen port (8089) in JVM (0):Address already in use: JVM_Bind.

In addition, there were no FSCK errors or IO errors reported in the system event viewer

Cause

This is Windows or Network issue where ports 8088 and 8089 are not listening. The issue is not due to a Unisphere problem.

Resolution

Network port 8088/8089 are not connecting this can be tested with Windows/DOS Test-NetConnection command or telnet command:

Test-NetConnection -ComputerName 127.0.0.1 -port 8088
Test-NetConnection -ComputerName 127.0.0.1 -port 8089

Products

Unisphere for PowerMax
Article Properties
Article Number: 000206894
Article Type: Solution
Last Modified: 05 Jun 2023
Version:  3
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