Unipshere dla PowerMax: Dane dotyczące wydajności nie są gromadzone

Summary: Dane dotyczące wydajności Unisphere na hostach Windows nie będą zbierać danych z powodu problemu z siecią lub systemem Windows.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Dane wydajności Unisphere na hoście Windows nie będą zbierać danych, porty 8088 i 8089 nie będą nasłuchuć z netstat.

The storsptd.log and the storstpd daemon could not send the processed performance data file DCF to the Postgres database via the default port 8088 and port 8089
Snippet from the storstpd.log:
                [3372 dcfSpaSender] Dec-02 13:02:23.316 pdsIpcClientConnInit #1813: Nie można ustanowić połączenia klienta [pdsSockSocket()/pdsSockConnect() failed], nRc= 700004019
[3372 dcfSpaSender] Dec-02 13:02:23.316: [sendFile()] TID: Identyfikator SID 740: 000497600171 nie można połączyć się z serwerem: 10.63.29.73 na porcie: 8088.
                [3372 dcfSpaSender] Dec-02 13:02:23.316: [dcfSpaSender()] TID: Plik przetwarzania błędów 740: 20221201_0205_000497600171_I.dcf.gz.
                [3372 SpaRtPackager] Dec-02 13:02:23.504 pdsSockConnect #2494: connect() failed: [fd= 1500] [Kod WSA: 10061 — nie można nawiązać połączenia, ponieważ komputer docelowy aktywnie go oznaczył.]
                [3372 SpaRtPackager] Dec-02 13:02:23.504 pdsIpcClientConnInit #1813: Nie można ustanowić połączenia klienta [pdsSockSocket()/pdsSockConnect() failed], nRc= 700004019


dzienniki bazy danych postgress pokazują, że system bazy danych został przerwany i regularnie uruchamia się:
            2022-12-01 12:41:15 GMT:127.0.0.1 (58618): wlp@wlp:[14116]:LOG: nie można odbierać danych z klienta: Host zdalny wymusił zamknięcie istniejącego połączenia.
            2022-12-01 12:41:15 GMT:127.0.0.1 (52768): spa@spa:[1424]:LOG: nie można odbierać danych z klienta: Host zdalny wymusił zamknięcie istniejącego połączenia.
            2022-12-01 12:41:15 GMT:127.0.0.1 (55006):spa@spa:[13544]:LOG: nie można odbierać danych z klienta: Host zdalny wymusił zamknięcie istniejącego połączenia.

Potwierdzono, że w dziennikach SMAS &RUN nie ma żadnych błędów wskazujących, że wymagane porty są używane przez inne procesy\aplikacje:
            Na przykład błąd [em.spa.SPA] (domyślnie EJB — 4) com.emc.em.spa.datamanager.datalistener.RTCListener.Exception in opening DCF listen port (8089) in JVM (0): Adres już używany: JVM_Bind.

Ponadto w podglądzie zdarzeń systemowych nie odnotowano błędów FSCK ani błędów we/wy

Cause

Jest to problem z systemem Windows lub siecią, w przypadku którego porty 8088 i 8089 nie nasłuchują. Problem nie wynika z problemu z Unisphere.

Resolution

Port sieciowy 8088/8089 nie łączy się, można to sprawdzić za pomocą polecenia Windows/DOS Test-NetConnection lub polecenia telnet:

Test-NetConnection -ComputerName 127.0.0.1 -port 8088
Test-NetConnection -ComputerName 127.0.0.1 -port 8089

Products

Unisphere for PowerMax
Article Properties
Article Number: 000206894
Article Type: Solution
Last Modified: 05 Jun 2023
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.