NetWorker : La création d’un nouveau client ne se termine pas avec le message « is not a valid hostname as it cannot be resolved in DNS »

Summary: L’ajout d’un client via de nouvelles propriétés client dans NetWorker 19.7.0.3 ne se termine pas et signale l’erreur « Name is not a valid hostname as it cannot be resolved in DNS. Veuillez l’ajouter au DNS ou au fichier des hôtes et vider le cache DNS du serveur NetWorker (dbgcommand -p FlushDnsCache). » ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

L’ajout d’un client via de nouvelles propriétés client dans NetWorker 19.7.0.3 ne se termine pas et affiche l’erreur suivante:
Name  is not a valid host name as it cannot be resolved in DNS.
Please add it to DNS or the hosts file and flush the NetWorker server's DNS cache (dbgcommand -p  FlushDnsCache).
 
Capture d’écran du message d’erreur
Figure 1 : Capture d’écran du message d’erreur

Cause

Le nom d’hôte échoue à la résolution du nom via DNS ou via le fichier « hosts ».

Même si le nom d’hôte est résolu, si ce message d’erreur s’est produit précédemment, le cache DNS NetWorker empêche l’ajout du client.

Resolution

Ajoutez le nom d’hôte du client au DNS (entrées directes et inverses) ou ajoutez-le au fichier « hosts » au format:

IP Address [space/tab] FQDN [space/tab] Short Name


Suivez les étapes ci-dessous pour « vider » le cache DNS NetWorker:

  1. Obtenez le PID des processus « nsrd » et « nsrexecd » à l’aide des commandes ci-dessous:

Windows :

tasklist | findstr nsrd.exe
tasklist | findstr nsrexecd.exe

Linux :

ps -e | grep nsrd
ps -e | grep nsrexecd
  1. Exécutez la commande ci-dessous en regard du PID « nsrd » et « nsrexecd » et utilisez le commutateur comme indiqué:
dbgcommand -p  FlushDnsCache
Article Properties
Article Number: 000212659
Article Type: Solution
Last Modified: 29 Jun 2023
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.