NetWorker: Creating a new client does not complete with message "is not a valid hostname as it cannot be resolved in DNS"

Summary: Adding a client through New Client Properties in NetWorker 19.7.0.3 does not complete, and reports an error "Name is not a valid hostname as it cannot be resolved in DNS. Please add it to DNS or the hosts file and flush the NetWorker server's DNS cache (dbgcommand -p FlushDnsCache)." ...

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Symptoms

Adding a client through New Client Properties in NetWorker 19.7.0.3 does not complete and displays the following error:
Name <CLIENTNAME> is not a valid host name as it cannot be resolved in DNS.
Please add it to DNS or the hosts file and flush the NetWorker server's DNS cache (dbgcommand -p <NetWorker server pid> FlushDnsCache).
 
Screenshot of Error message
Figure 1: Screenshot of Error message

Cause

The hostname fails name resolution either through DNS or through the 'hosts' file.

Even if the hostname resolves, if this error message occurred previously, the NetWorker DNS Cache prevents the client from being added.

Resolution

Add the client hostname to DNS (forward and reverse entries) or add it to the 'hosts' file using the format:

IP Address [space/tab] FQDN [space/tab] Short Name


Follow the steps below to "flush" the NetWorker DNS Cache:

  1. Obtain the PID of the 'nsrd' and 'nsrexecd' processes using the below commands:

Windows:

tasklist | findstr nsrd.exe
tasklist | findstr nsrexecd.exe

Linux:

ps -e | grep nsrd
ps -e | grep nsrexecd
  1. Run the below command against the PID of the 'nsrd' and 'nsrexecd' and use the switch as shown:
dbgcommand -p <PID> FlushDnsCache
Article Properties
Article Number: 000212659
Article Type: Solution
Last Modified: 29 Jun 2023
Version:  3
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