Avamar: Backup SQL non riuscito, client non esplorabile, backup non riuscito con codice errore: 10007
Summary: Backup SQL non riuscito, il client non è in grado di sfogliare e backup non riuscito con un codice di errore: 10007.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Il backup SQL non è riuscito, il client non è in grado di eseguire l'esplorazione e il backup è stato completato con un codice di errore: 10007
Parte pertinente del registro di backup:
Parte pertinente del registro di backup:
2013-09-23 00:00:01 avsql Info <5008>: Logging to C:\Program Files\avs\var\Daily-12am-RxSQL-1379912400061-3006-SQL.log 2013-09-23 00:00:01 avsql Info <6673>: CTL listening on port 56505 2013-09-23 00:00:01 avsql Info <10684>: Setting ctl message version to 3 (from 1) 2013-09-23 00:00:01 avsql Info <16136>: Setting ctl max message size to 268435456 2013-09-23 00:00:01 avsql Info <7838>: - Adding user exclude "*/tempdb" 2013-09-23 00:00:02 avsql Error <9072>: sqlconnectimpl_smo::get_installed_instance_list Microsoft.SqlServer.Management.Smo.FailedOperationException: An exception occurred in SMO while trying to manage a service. ---> Microsoft.SqlServer.Management.Sdk.Sfc.EnumeratorException: Failed to retrieve data for this request. ---> System.Management.ManagementException: Invalid class
Quando il cliente apre SQL Server Configuration Manager in SQL Server, il messaggio di errore è: "Impossibile connettersi al provider WMI. Non si dispone dell'autorizzazione o il server non è raggiungibile.
Cause
Si tratta di un problema di Microsoft WMI come riportato nell'articolo della Knowledge Base di Microsoft:
https://learn.microsoft.com/en-us/troubleshoot/sql/tools/error-message-when-you-open-configuration-manager
"Questo problema si verifica perché il provider WMI viene rimosso quando il cliente disinstalla un'istanza di SQL Server. L'istanza a 32 bit e l'istanza a 64 bit di SQL Server condividono lo stesso file di configurazione WMI. Questo file si trova nella cartella "C:\Program Files (x86)\Microsoft SQL Server\xxx\Shared".
Questa situazione può talvolta verificarsi durante l'aggiornamento di SQL.
https://learn.microsoft.com/en-us/troubleshoot/sql/tools/error-message-when-you-open-configuration-manager
"Questo problema si verifica perché il provider WMI viene rimosso quando il cliente disinstalla un'istanza di SQL Server. L'istanza a 32 bit e l'istanza a 64 bit di SQL Server condividono lo stesso file di configurazione WMI. Questo file si trova nella cartella "C:\Program Files (x86)\Microsoft SQL Server\xxx\Shared".
Questa situazione può talvolta verificarsi durante l'aggiornamento di SQL.
Resolution
Se il riavvio del servizio WMI sul client SQL interessato non risolve il problema, attenersi alle istruzioni riportate nell'articolo della Knowledge Base di Microsoft:
https://learn.microsoft.com/en-us/troubleshoot/sql/tools/error-message-when-you-open-configuration-manager
Per risolvere questo problema, aprire un prompt dei comandi, digitare il seguente comando e quindi premere INVIO:
https://learn.microsoft.com/en-us/troubleshoot/sql/tools/error-message-when-you-open-configuration-manager
Per risolvere questo problema, aprire un prompt dei comandi, digitare il seguente comando e quindi premere INVIO:
Ad esempio: Per il server Windows SQL 2008/R2 la riga di comando è:
mofcomp "C:\Program Files (x86)\Microsoft SQL Server\100\Shared\sqlmgmproviderxpsp2up.mof"
Versioni successive SQL 2022
mofcomp "C:\Program Files (x86)\Microsoft SQL Server\160\Shared\sqlmgmprovider.mof"
Successivamente, verifica che il cliente possa aprire SQL Server Configuration Manager in SQL Server senza errori e che il client SQL possa navigare nella GUI di amministrazione di Avamar o in AUI:> vengono elencati il backup e tutti i database/istanze.
Affected Products
Avamar Plug-in for SQLArticle Properties
Article Number: 000040204
Article Type: Solution
Last Modified: 11 Jul 2024
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.