Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Connectrix Série B: não é possível coletar o ConfigUpload ou o Supportsave via SCP e SFTP

Summary: Não foi possível coletar supportsaves ou o configupload falha

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms



Não é possível coletar "supportsaves" ou "configupload" por Secure Copy (SCP) e Secure File Transfer Protocol (SFTP).

Confirme o seguinte antes de continuar:

1. O switch consegue fazer ping no servidor SCP/SFTP.
2. O servidor SCP/SFTP também pode executar ping switch.
3. Nenhum firewall bloqueando as portas SCP ou SFTP.
4. Funciona com FTP.

Também pode ocorrer durante o upgrade do FOS 7.1.x para 7.4.x.

Exemplo de SCP:
switch:admin> configupload
Protocolo (scp, ftp, sftp, local) [ftp]: scp
Deseja continuar com a CRA (S/N) [N]: y
Nome do servidor ou endereço IP [host]: 10.0.0.1
Nome de usuário [usuário]: admin
Caminho/Nome do arquivo [<diretório> inicial/config.txt]: /configupload.scp
Seção (all|chassis|switch [all]): switch
lost connection
configUpload not allowed (scp failed).
SFTP encerrado


Exemplo:
switch:admin> supportsave
Este comando coleta dados
de RASLOG, TRACE, supportShow, core file, FFDC e os transfere para um servidor FTP/SCP/SFTP ou um dispositivo USB.
Essa operação pode levar vários minutos.
NOTA: o supportSave transferirá primeiro o dump file de rastreamento existente e, em seguida
, gerará e transferirá automaticamente o arquivo mais recente. Haverá dois dump files de rastreamento
transferidos após esse comando.
OK para prosseguir? (sim, s, não, n): [não] y

IP do host ou nome do host: 10.0.0.1
Nome de usuário: admin
Senha:
Protocol (ftp | scp | sftp): sftp
Remote Directory: /

Deseja continuar com CRA (S/N) [N]: y
Salvando informações de suporte para switch:switch, module:RAS...

....................................................................................Host remoto: não foi possível se conectar ao host remoto.
Falha no SupportSave.


Se a CRA (Challenge Response Authentication, autenticação de resposta de desafio) for escolhida como "NO" ou "N" e o problema ainda ocorrer e/ou o acesso root não estiver disponível, siga a Resolução 2.

Cause

O arquivo known_hosts tem uma chave pública incorreta que está impedindo a autenticação de saída com o servidor scp/sftp. 
Isso geralmente ocorre se o servidor tiver que ser reconstruído e, ao fazer isso, as informações da "chave" forem alteradas e, assim, sempre que um supportsave for executado, a "chave" enviada do switch será diferente da listada no servidor, causando a 'falha na conexão' Mensagem. 
 

    Resolution

    Para corrigir esse problema, será necessário acesso root ao switch para remover o host da entrada RSA do switch no arquivo known_hosts.  Quando o switch fizer sua próxima conexão, uma nova chave RSA será gerada e propagada para o arquivo known_hosts para permitir acesso à conclusão da coleta de dados.

    Siga estas etapas:
    Resolução 1:

    1. Faça log-in no switch como "root"
    2. Digite o seguinte comando para remover a chave RSA pública do servidor scp/sftp:

      ssh-keygen -R XXX.XXX.XXX.XXX (em que XXX.XXX.XXX.XXX representa o endereço IP do servidor scp/sftp
    Resolução 2:
    1. Faça log-in no switch como "admin"
    2. Remova o endereço IP do SFTP/SCP da lista de hosts conhecidos:
    ># sshutil delknownhost 
    O switch solicitará a inserção do endereço IP do servidor SFTP cuja entrada precisa ser removida.
    Endereço IP/Nome do host a ser excluído: <Endereço IP do servidor SFTP>

    Depois disso, quando o supportsave ou configupload é tentado, o endereço IP do host é adicionado à lista de known_host.

    Article Properties


    Last Published Date

    20 Nov 2020

    Version

    2

    Article Type

    Solution