Data Protection Advisor (DPA): Agent logs error opening the required pstore or cannot open pstore

Summary: DPA agent logs error opening pstore or cannot open pstore

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



The following errors are logged by the agent during data collection or during startup:

ERR     32432.44128    20191026:105133         clctr.module - aapiRunRequest(): Unable to run request networker:status as there was an error opening the required pstore D:\Program Files\agent\data\networker_status_NWservername_NetWorker.db.
ERR     46268.18960    20191026:110342 common.localdb.sqlit - csqlRollbackTransaction(): Attempt to rollback without an active transaction
ERR     46268.18960    20191026:110342  com.mod.agentconfig - loadAgentRegisteredConfig(): Error loading agent registered config: cannot open pstore: D:\Program Files\agent\data\agent_config.db
ERR     46268.18960    20191026:110343 common.localdb.pstor - pstoreOpen(): Failed to begin transaction
ERR     46268.18960    20191026:110343  com.mod.agentconfig - loadAgentRegistrationCredentials(): Error loading agent registration credentials: cannot open pstore: D:\Program Files\agent\data\agent_config.db


Cause

McAfee anti-virus product was installed on the agent host and actively scanning the DPA Agent folder.

Resolution

Configure exclusion within McAfee software to not actively scan the DPA Agent folder.  Below is the default install directory on Windows for the DPA Agent:

<Install directory>\emc\dpa\agent

Affected Products

Data Protection Advisor

Products

Data Protection Advisor
Article Properties
Article Number: 000055543
Article Type: Solution
Last Modified: 25 Jul 2025
Version:  3
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