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Article Number: 000056057


Deployment KB: Elastic Cloud Storage (ECS): BMC (IPMI) not Responding on the following nodes (IPMI Disabled)

Summary: xDoctor reports BMC (IPMI IPs are not responding).

Article Content


Symptoms

xDoctor reports BMC (IPMI) not responding:
Timestamp = 2019-02-11_083547
Category = IPMI
Source = OS
Severity = WARNING
Message = BMC (IPMI) not Responding on the following nodes
Extra = 169.254.1.3,169.254.1.4,169.254.1.6
When running xDoctor, it reports BMC (IPMI) not responding on the above nodes and the list of IP private IP addresses that is not responding.

We can ping the IP address, but we cannot use the IPMI tool with internal IP. However, we can use the BMC IPs to use IPMI tools.

Cause

We encounter such issues when IPMI is disabled:
  • BMC failing External authentication:
# for i in $(seq 1 8); do echo $i;ipmitool -H 192.168.219.10$i -U root -P passwd -I lanplus chassis power status; done 

Expected Output Similar to:

1
Error: Unable to establish IPMI v2 / RMCP+ session
2
Error: Unable to establish IPMI v2 / RMCP+ session
3
Error: Unable to establish IPMI v2 / RMCP+ session
4
Error: Unable to establish IPMI v2 / RMCP+ session
5
Chassis Power is on
6
Chassis Power is on
7
Chassis Power is on
8
Chassis Power is on
  • BMC responds without authentication internally:
# domulti ipmitool chassis power status

Expected Output Similar to:
  
192.168.219.1
========================================
Chassis Power is on
  
192.168.219.2
========================================
Chassis Power is on
  
192.168.219.3
========================================
Chassis Power is on
  
192.168.219.4
========================================
Chassis Power is on
  
192.168.219.5
========================================
Chassis Power is on
  
192.168.219.6
========================================
Chassis Power is on
  
192.168.219.7
========================================
Chassis Power is on
  
192.168.219.8
========================================
Chassis Power is on
  • Log in to the node where IPMI is having issues and check if LAN access is disabled:
# sudo ipmitool channel info 1

Expected Output Similar to:
 
Channel 0x1 info:
  Channel Medium Type   : 802.3 LAN
  Channel Protocol Type : IPMB-1.0
  Session Support       : multi-session
  Active Session Count  : 0
  Protocol Vendor ID    : 7154
  Volatile(active) Settings
    Alerting            : enabled
    Per-message Auth    : enabled
    User Level Auth     : enabled
    Access Mode         : disabled
  Non-Volatile Settings
    Alerting            : enabled
    Per-message Auth    : enabled
    User Level Auth     : enabled
    Access Mode         : disabled <-- Lan access DISABLED.

Resolution

In case IPMI is disabled, confirm with user if it was disabled for a reason. If not, get permission from user to enable it.
  • Run the following command to enable it on the same node:
# sudo ipmitool lan set 1 access on
 
Expected Output Similar to:

Set Channel Access for channel 1 was successful.
  • Check the LAN access after enabling that it should be Always Enabled:
# sudo ipmitool channel info 1

 Expected Output Similar to:

Channel 0x1 info:
  Channel Medium Type   : 802.3 LAN
  Channel Protocol Type : IPMB-1.0
  Session Support       : multi-session
  Active Session Count  : 0
  Protocol Vendor ID    : 7154
  Volatile(active) Settings
    Alerting            : enabled
    Per-message Auth    : enabled
    User Level Auth     : enabled
    Access Mode         : always available
  Non-Volatile Settings
    Alerting            : enabled
    Per-message Auth    : enabled
    User Level Auth     : enabled
    Access Mode         : always available  <-- Always Enabled.
  • Verify that all nodes are responding over LAN:
# for i in $(seq 1 8); do echo $i;ipmitool -H 192.168.219.10$i -U root -P passwd -I lanplus chassis power status; done

1
Chassis Power is on
2
Chassis Power is on
3
Chassis Power is on
4
Chassis Power is on
5
Chassis Power is on
6
Chassis Power is on
7
Chassis Power is on
8
Chassis Power is on

Article Properties


Affected Product

Elastic Cloud Storage

Product

ECS Appliance Hardware Series, ECS Appliance Software with Encryption, ECS Appliance Software without Encryption, Elastic Cloud Storage

Last Published Date

15 Dec 2022

Version

5

Article Type

Solution