Isilon: OneFS: Brak informacji o zewnętrznym dostawcy uwierzytelniania dla nowo dodanego węzła

Summary: Isilon: OneFS: Brak informacji o zewnętrznym dostawcy uwierzytelniania dla nowo dodanego węzła

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Nowo dodany węzeł może nie wykazywać takiego samego stanu uwierzytelniania jak oryginalne węzły klastra. W poniższym przykładzie węzły 4–6 to nowo dodane węzły, które nie widzą domeny, do której jest przyłączony klaster:

# isi_for_array -s "isi auth status | grep -i corp.xxx.org " 
xxx-ISILON-1: lsa-activedirectory-provider:CORP.xxx.ORG xxx.xxx.xxx.org online 
xxx-ISILON-2: lsa-activedirectory-provider:CORP.xxx.ORG xxx.xxx.xxx.org online 
xxx-ISILON-3: lsa-activedirectory-provider:CORP.xxx.ORG xxx.xxx.xxx.org online 
xxx-ISILON-4 exited with status 1 
xxx-ISILON-5 exited with status 1 
xxx-ISILON-6 exited with status 1 


 

Cause

Jeśli węzeł zostanie dodany do klastra przed zaimplementowaniem konfiguracji sieci, usługa lsass mogła wyczerpać dozwoloną liczbę prób wysłania zapytania do zewnętrznego dostawcy uwierzytelniania w celu załadowania konfiguracji. Po udostępnieniu trasy z węzła do dostawcy uwierzytelniania (okablowanie, konfiguracja sieci zewnętrznej i dodanie nowych interfejsów węzłów do puli sieci, które mogą dotrzeć do dostawcy uwierzytelniania), proces lsass nie jest automatycznie monitowany o ponowne wysłanie zapytania.

Resolution

Uruchom to polecenie na nowych węzłach, aby odświeżyć konfigurację, a węzeł spróbuje ponownie połączyć się ze wszystkimi skonfigurowanymi zewnętrznymi dostawcami uwierzytelniania:

# isi auth refresh

lub polecenie

# isi_for_array -n <Low LNN-High LNN> 'isi auth refresh'

W tym przykładzie polecenie powinno wyglądać następująco:

# isi_for_array -n 4-6 'isi auth refresh'

Jedną z metod rozwiązania tego problemu jest użycie reguł aprowizacji węzłów do automatycznego konfigurowania interfejsów w określonych pulach sieciowych.

Więcej informacji można znaleźć w Podręczniku administratora OneFS. W przypadku OneFS 8.0.0.x należy zapoznać się z informacjami zaczynającymi się od strony 960: https://support.emc.com/docu65065_OneFS-8.0.0-CLI-Administration-Guide.pdf?language=en_US



 

Additional Information

Może być konieczne ponowne uruchomienie usługi lsass. Uwaga: Jest to polecenie dla każdego węzła.

# /usr/likewise/bin/lwsm restart lsass



Affected Products

PowerScale OneFS

Products

Isilon, PowerScale OneFS
Article Properties
Article Number: 000061569
Article Type: Solution
Last Modified: 22 Apr 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.