Data Protection Advisor: Agenten kan ikke registrere sig på serveren

Summary: Data Protection Agent (DPA) kan ikke registreres på DPA APP-serveren (Data Protection Application) på grund af HTTP-proxyindstillingen (Hyper-Text Transfer Protocol), hvilket resulterer i kommunikations-URL-fejl (CURL) [56] og HTTP-kode (Hyper-Text Transfer Protocol) 403. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Agent vises ikke i brugergrænsefladen under Dataindsamlingsagenter>, selvom agenten er installeret.

Når agenten er indstillet til fejlfinding, skal du finde følgende skærme i agentloggen:
 

DBG1    18535.18535    20170628:142552             com.http - httpSendRequest(): CURL error: [56] Received HTTP code 403 from proxy after CONNECT
ERR     18535.18535    20170628:142552         agent.config - initAgentConfig(): Failed to register agent with the server. Waiting to retry...


 

Cause

En http-proxyindstilling forårsager dette problem, hvilket medfører, at DPA APP-serveren afviser agentregistreringsanmodningen ved tilslutning.

Resolution

Log på DPA-agentserveren som root, og gør følgende:

Stop DPA-agenttjenesten med følgende kommando:

/opt/emc/dpa/agent/etc/dpa stop


Rediger filen dpa.custom, som findes i DPA-installationsmappen>/dpa/agent/etc-mappen<, og tilføj følgende to linjer:
 

export http_proxy=
export https_proxy=
 
De to ovenstående linjer skal oprettes nøjagtigt som ovenfor uden yderligere tegn ud over =.


Gem ændringerne, og genstart agenttjenesten. Helpdesk-medarbejderen bør registrere sig nu, da de nye poster i filen dpa.custom fjerner alle http- eller https-proxyindstillinger på operativsystemniveau. 

Kontakt Dells tekniske support for at få flere oplysninger.

 

Products

Data Protection Advisor
Article Properties
Article Number: 000065495
Article Type: Solution
Last Modified: 24 Jun 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.