Dell Direct USB Key - FAQs
Summary: Learn about the Dell Direct USB drive and how to use it to recover the operating system on your Dell personal computer.
Symptoms
Table of Contents:
- Video on Dell Direct USB Key
- What is a Dell Direct USB Key?
- What will the Dell Direct USB Key install?
- How to use the Dell Direct USB Key?
- Additional Information
Using the Windows 8 USB Recovery Key
Duration: 04:52 (mm:ss format)
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Dell OS Recovery and Restore USB Key
Duration: 03:37 (mm:ss format)
When available, closed caption (subtitles) language settings can be chosen using the Settings or CC icon on this video player.
What is a Dell Direct USB Key?
The Dell Direct USB Key is designed to provide a quick resolution if there is an operating system issue, without the loss of data.
- Fast and user-friendly efficient solution to fix your OS issues
- Help diagnose the issue and find the best solution (even if your computer is not able to load OS)
- Assist you in automatic back-up and restoration of your personal data and settings
- Automated Reinstallation of Operating System
- Customizable data backup
- Optical drive free or Disk free operations
- Exclusive product from Dell
Cause
Cause information is not available.
Resolution
What will the Dell Direct USB Key install?
The key installs the following:
- Operating System - Windows 7 or Windows 8 (based on the version originally shipped with the personal computer).
- Basic device drivers (additional device drivers may be required. See Dell knowledge-base article Drivers and downloads FAQs.
- Applications
- Windows 7
- Dell Data Safe Local (DSL)
- Dell Digital Delivery (DDD)
- My Dell
- Link to Microsoft Office Trial
- Microsoft Windows 8.1, Windows 8, or Windows 10
- Dell Backup and Recovery (DBAR)
- Dell Digital Delivery
- My Dell
- Link to Microsoft Office Trial
- Windows 7
How to use the Dell Direct USB Key?
- Power off the personal computer.
- Disconnect all external devices except the keyboard and mouse (and monitor if there is a desktop personal computer). For laptop PCs, ensure that the power adapter is connected.
- Connect the Dell Direct USB Key to one of the USB ports.
- Power on the personal computer and tap F12 key on the keyboard.
- Highlight the following (based on the operating system) and press Enter.
- Windows 7:
USB Storage Device
Toshiba Device - Windows 8.1, Windows 8, or Windows 10:
EFI USB path 1
Toshiba MSFT NORB PMAP (if you have multiple choices, select the first one)
USB Storage Device
- Windows 7:
- Select the language.
Note: This is the display language of the Dell Direct USB Key process, and may be the same for the operating system, select accordingly.
- In the End User License Agreement, scroll to the bottom, check "I Accept" and click Continue.
- The next screen will provide the "Process Overview," click Continue.
- Once the process is completed, it provides an analysis of the test performed.
- Click Continue or Exit based on the analysis provided.
Note: If the issue is fixed, clicking Exit restarts the system back to the desktop.
- Click Continue. Connect an external storage device for data backup when prompted.
- Click Select More to browse and add additional files to be backed up.
- Click Continue once you have selected all the required files for backup.
Note: If the external storage device is not detected, it prompts to connect the external storage device.
- Once the data backup is complete, click Continue.
- Click Continue to start the operating system restoration (do not disconnect the external storage device until prompted).
- Once the process is complete, click Restart.
Note: The Restart button is grayed out. Unplug the Dell Direct USB Key and any external storage device and then click Restart.
- The personal computer restarts a few times and prompts to connect the external storage device.
After all the restarts, the personal computer will boot into the operating system. Confirm that all the data has been restored. If all the data is restored, the entire process is complete. You may now go to setup personal settings, application installation, and so forth,
Follow the instructions below only if the backed-up data could not be restored.
- Restore backup your data.
- Create a new folder on the desktop and name it "Migration Utility"
- Extract the file in the folder created
- Ensure that the following files are in the folder:
MigRestore.exe
SDSImageTools.dll
SDSMigrationTools.dll
SKIP - Connect the external storage device with the backed-up data
- Double-Click on MigRestore.exe (For any opening Windows confirmation, click 'Yes' to run MigRestore.exe)
- Click Browse and select the external storage device
- Click Restore to begin data restore process
Once the process is complete, the backed-up data is restored
Additional Information
Additional Information
- Language
- Keyboard Settings
- Currency
- Date/Time Format
- Time Zone
- Windows Color and Appearance
- Desktop Background
- Screen saver
- Sounds
- Mouse pointers
- Windows Themes
- Windows Display Settings
- Profile Picture
- Network Settings
- Internet Favorites
- Browser Settings (Internet Explorer only)
- Power Profiles
- Task bar
- Start Menu Settings
- Accessibility
After the data has been restored can I delete the restoration file from the external storage device?
As for users with Windows Mail, the user has to ensure that the path C:\Users\[username]\AppData\Local\Microsoft\Windows Mail\ is backed up.
If you are using any other email application, see the software manufacturer for more information on how to back up emails in that email application.