PowerStore: pstcli command "support_metrics_archive generate" returns the wrong data as a response
Summary: The PowerStore CLI (PSTCLI) command "support_metrics_archive generate" returns wrong data as a response.
Symptoms
The PowerStore CLI (PSTCLI) command "support_metrics_archive generate" returns wrong data as a response.
Example:
pstcli -service support_metrics_archive generate -start_offset 604800 -end_offset 0 Success # | archive_id ----+-------------- 1 | (wrong data)
Cause
This is a known issue in PSTCLI in versions up to 1.0.2.x.
Resolution
This issue is fixed in PowerStoreOS 1.0.3.0.5.007 (v1.0 Service Pack 3).
As a workaround, the available performance archives are found inside the following directory, where xxxx is a date folder or folders specific to your system.
ll /cyc_cfs/service/support_metrics/archived/xxxx
The file format is PowerStore_ClusterID_StartDate_EndDate_support-metrics.tar.gz.
Example: PowerStore_abcdefg_2020-04-21T12-56-32_2020-04-28T12-56-32_support-metrics.tar.gz
For guidance on how to download logs from a PowerStore system, see PowerStore: How to generate and collect various logs from PowerStore
Additional Information
Important Note
A new issue was found in PSTCLI in PowerStoreOS 1.0.3.0.5.007, where the downloaded file (with pstcli command "support_metrics_archive download") is saved with the generated ID instead of the correct file name.
This is cosmetic only as the file can still be extracted (it is still a tar.gz file) and the contents are as they should be.
This issue is fixed in PowerStoreOS v2.1.x.