Article Number: 000157682


VxRail: VxRail and external vCenter interoperability matrix

Summary: List appropriate external vCenter versions for use with VxRail

Article Content


Instructions

This article details appropriate external vCenter versions for use with VxRail.

To see specific VxRail versions and each component code levels, refer to the following:    

VxRail upgrade paths are found in the Upgrade Paths section in the VxRail Release notes. These are found at:    


Change to External vCenter version pre-check in VxRail Appliance Software 7.0.130 and later for cluster installations or node additions
With VxRail Appliance Software 7.0.130 and later, VxRail no longer validates if an External or customer-supplied vCenter server software version is compatible with the VxRail Appliance Software version on the cluster. Ensure that your External vCenter server is upgraded to the minimum compatible version before initiating the installation of the cluster (or before adding the new node to the cluster).


External vCenter 7.0 support
External vCenter 7.0 is natively supported with VxRail Appliance Software 7.0.xxx releases.

Support is added to earlier VxRail Appliance Software releases starting with:    

  • VxRail Appliance Software version 4.5.400 and later 4.5 releases
  • VxRail Appliance Software version 4.7.300 and later 4.7 releases

Note: There are additional considerations and known issues associated with the use of External vCenter 7.0 and earlier VxRail Appliance Software versions. These are documented in KB article 544040: (Only Customers can access the content on the following link to Dell.com/support) Dell EMC VxRail: External vCenter 7.0 considerations with VxRail Appliance Software releases 4.5.x and 4.7.x  and should be reviewed before considering upgrading vCenter to 7.0.


Matrix of supported external vCenter versions with VxRail

VxRail Release

ESXi (Version - Build #)

External vCenter versions

 

Minimum

Recommended

7.0.132 7.0 U1d - 17551050 7.0 U1 (7.0.1) 7.0 U1c (7.0.1.00200) or later
7.0.131 7.0 U1d - 17551050 7.0 U1 (7.0.1) 7.0 U1c (7.0.1.00200) or later
7.0.130 7.0 U1c - 17325551 7.0 U1 (7.0.1) 7.0 U1c (7.0.1.00200) or later
7.0.101 7.0 EP02 - 17168206 7.0 U1 (7.0.1) 7.0 U1 (7.0.1) or later
7.0.100 7.0 U1 - 16850804 7.0 U1 (7.0.1) 7.0 U1 (7.0.1) or later
7.0.010 7.0b - 16324942 7.0 GA 7.0.0b or later
7.0.000 7.0 GA - 15843807 7.0 GA 7.0 GA or later

4.7.526

6.7 P04 - 17167734

6.7 U3 / 7.0 GA

6.7 U3l or later / 7.0 GA or later

4.7.525

6.7 P04 - 17167734

6.7 U3 / 7.0 GA

6.7 U3i or later / 7.0 GA or later

4.7.521

6.7 EP17 - 17098360

6.7 U3 / 7.0 GA

6.7 U3j or later / 7.0 GA or later

4.7.520

6.7 EP16 - 16773714

6.7 U3 / 7.0 GA

6.7 U3j or later / 7.0 GA or later

4.7.515 19

6.7 P03 - 16713306

6.7 U3 / 7.0 GA

6.7 U3j or later / 7.0 GA or later

4.7.511 16

6.7 EP15 - 16316930

6.7 U3 / 7.0 GA

6.7 U3g or later / 7.0 GA or later

4.7.510

6.7 P02 - 16075168

6.7 U3 / 7.0 GA

6.7 U3g or later / 7.0 GA or later

4.7.411 14 15

6.7 EP14 - 15820472

6.7 U3 / 7.0 GA

6.7 U3f or later / 7.0 GA or later

4.7.410 15

6.7 P01 - 15160138

6.7 U3 / 7.0 GA

6.7 U3b or later / 7.0 GA or later

4.7.301 12 15

6.7 EP13 - 15018017

6.7 U3 / 7.0 GA

6.7 U3a or later / 7.0 GA or later

4.7.300 15

6.7 U3 - 14320388

6.7 U3 / 7.0 GA

6.7 U3 or later / 7.0 GA or later

4.7.212 11

6.7 EP10 - 13981272

6.7 U2

6.7 U2c or later

4.7.211 10

6.7 EP09 - 13644319

6.7 U2

6.7 U2a or later

4.7.210 10

6.7 EP09 - 13644319

6.7 U2

6.7 U2a or later

4.7.200

6.7 U2 - 13006603

6.7 U2

6.7 U2 or later

4.7.111

6.7 EP07 - 13004448

6.7 U1

6.7 U1 or later

4.7.110

6.7 EP06 - 11675023

6.7 U1

6.7 U1 or later

4.7.100

6.7 EP06 - 11675023

6.7 U1

6.7 U1 or later

4.7.001

6.7 EP05 - 10764712

6.7 U1

6.7 U1 or later

4.7.000

6.7 EP05 - 10764712

6.7 U1

6.7 U1 or later

4.5.452

6.5 EP23 - 17167537

6.5 U3 / 6.7 U2a / 7.0 GA

6.5 U3k or later / 6.7 U3b or later / 7.0 GA or later

4.5.451

6.5 EP21 - 16901156

6.5 U3 / 6.7 U2a / 7.0 GA

6.5 U3k or later / 6.7 U3b or later / 7.0 GA or later

4.5.450 18

6.5 P05 - 16576891

6.5 U3 / 6.7 U2a / 7.0 GA

6.5 U3k or later / 6.7 U3b or later / 7.0 GA or later

4.5.422 17

6.5 EP20 - 16389870

6.5 U3 / 6.7 U2a / 7.0 GA

6.5 U3f or later / 6.7 U3b or later / 7.0 GA or later

4.5.420 13

6.5 P04 - 15256549

6.5 U3 / 6.7 U2a / 7.0 GA

6.5 U3f or later / 6.7 U3b or later / 7.0 GA or later

4.5.402 13

6.5 EP18 - 15266363

6.5 U3 / 6.7 U2 / 7.0 GA

6.5 U3d or later / 6.7 U3a or later / 7.0 GA or later

4.5.401 12 13

6.5 EP17 - 14990892

6.5 U3 / 6.7 U2 / 7.0 GA

6.5 U3d or later / 6.7 U3a or later / 7.0 GA or later

4.5.400 13

6.5 U3 - 13932383

6.5 U3 / 6.7 U2 / 7.0 GA

6.5 U3 or later / 6.7 U2a or later / 7.0 GA or later

4.5.314 10

6.5 EP14 - 13635690

6.5 U2g / 6.7 U2

6.5 U2g or later / 6.7 U2a or later

4.5.311 9

6.5 EP13 - 13004031

6.5 U2c / 6.7 U1

6.5 U2c or later / 6.7 U1 or later

4.5.310 9

6.5 P03 - 10884925

6.5 U2c / 6.7 U1

6.5 U2c or later / 6.7 U1 or later

4.5.300 9

6.5 P03 - 10884925

6.5 U2c / 6.7 U1

6.5 U2c or later / 6.7 U1 or later

4.5.229 8

6.5 EP11 - 10719125

6.5.U2c / 6.7 U1

6.5.U2c or later / 6.7 U1 or later

4.5.227 7

6.5 EP10 - 10390116

6.5.U2c / 6.7 U1

6.5.U2c or later / 6.7 U1 or later

4.5.225 6

6.5 EP09 - 10175896

6.5.U2c / 6.7 U1

6.5.U2c or later / 6.7 U1 or later

4.5.218 5

6.5 U2C - 9298722

6.5.U2c / 6.7 U1

6.5.U2c or later / 6.7 U1 or later

4.5.215

6.5 EP07 - 8935087

6.5 U2b / 6.7 U1

6.5 U2b or later / 6.7 U1 or later

4.5.212 4

6.5 EP07 - 8935087

6.5 U2b

6.5 U2b or later

4.5.211

6.5 U2 - 8294253

6.5 U2

6.5 U2 or later

4.5.210 2

6.5 U2 - 8294253

6.5 U2

6.5 U2 or later

4.5.200 3

6.5 P02 - 7388607

6.5 U1

6.5 U1a or later

4.5.152 2

6.5 EP06 - 7967591

6.5 U1g

6.5 U1g or later

4.5.150

6.5 P02 - 7388607

6.5 U1

6.5 U1a or later

4.5.070

6.5 EP04 - 6765664

6.5 U1

6.5 U1a or later

4.5.000

6.5 U1 - 5969303

6.5 U1

6.5 U1 or later

 

Matrix of supported external vCenter versions with older VxRail releases

VxRail Release

ESXi (Version - Build #)

External vCenter versions

 

Minimum

Recommended

4.0.603

6.0 EP25 - 15517548

6.0 U3i / 6.5 U2g / 6.7 U2a

6.0 U3j or later / 6.5 U2g or later / 6.7 U2a or later

4.0.602

6.0 EP23 - 15169789

6.0 U3i / 6.5 U2g / 6.7 U2a

6.0 U3j or later / 6.5 U2g or later / 6.7 U2a or later

4.0.601 12

6.0 EP22 - 15018929

6.0 U3i / 6.5 U2g / 6.7 U2a

6.0 U3j or later / 6.5 U2g or later / 6.7 U2a or later

4.0.600

6.0 P08 - 14513180

6.0 U3i / 6.5 U2g / 6.7 U2a

6.0 U3j or later / 6.5 U2g or later / 6.7 U2a or later

4.0.524 10

6.0 EP21 - 13635687

6.0 U3i / 6.5 U2g / 6.7 U2a

6.0 U3i or later / 6.5 U2g or later / 6.7 U2a or later

4.0.523

6.0 EP20 - 13003896

6.0 U3h / 6.7 U1

6.0 U3h or later / 6.7 U1 or later

4.0.522 8

6.0 EP19 - 10719132

6.0 U3h / 6.7 U1

6.0 U3h or later / 6.7 U1 or later

4.0.521 7

6.0 EP18 - 10474991

6.0 U3h / 6.7 U1

6.0 U3h or later / 6.7 U1 or later

4.0.520 5

6.0 EP15 - 9313334

6.0 U3h / 6.7 U1

6.0 U3h or later / 6.7 U1 or later

4.0.510

6.0 P07 - 9239799

6.0 U3g

6.0 U3g or later

4.0.500 4

6.0 EP14 - 8934903

6.0 U3f / 6.5 U2b

6.0 U3f / 6.5 U2b or later

4.0.402 2

6.0 EP13 - 7967664

6.0 U3e / 6.5 U1g

6.0 U3e / 6.5 U1g or later

4.0.401

6.0 P06 - 6921384

6.0 U3 / 6.5 U1

6.0 U3d / 6.5 U1e or later

4.0.400

6.0 P06 - 6921384

6.0 U3 / 6.5 U1

6.0 U3c / 6.5 U1 or later

4.0.310

6.0 P05 - 5572656

6.0 U3 / 6.5 U1

6.0 U3b / 6.5 U1 or later

4.0.302

6.0 EP11 - 6765062

6.0 U3

6.0 U3b or later

4.0.301

6.0 P05 - 5572656

6.0 U3

6.0 U3b or later

4.0.300

6.0 P05 - 5572656

6.0 U3

6.0 U3b or later

4.0.200

6.0 EP07a - 5224934

6.0 U3

6.0 U3 or later

4.0.132

6.0 U3 - 5050593

6.0 U3

6.0 U3 or later

4.0.100

6.0 U2 P04 - 4600944

6.0 U2

6.0 U2a or later

4.0.001

6.0 U2 P04 - 4600944

6.0 U2

6.0 U2a or later

4.0

6.0 U2 P03 - 4192238

6.0 U2

6.0 U2 or later

3.5 1

6.0 U2 - 3620759

6.0 U2

6.0 U2 or later

3.0

6.0 U1b - 3380124

N/A

N/A


To cross reference vCenter versions with build numbers, see VMware KB: Build numbers and versions of VMware vCenter Server (2143838)

Additional Information
VxRail upgrades and External vCenter
When upgrading VxRail to a later build, verify the current external vCenter build is already at the minimum version required for the VxRail build you are planning to upgrade to.

If a vCenter upgrade is required, it is a requirement to upgrade an External vCenter before upgrading the VxRail appliance software.

Refer to the VxRail Appliance Software Release Notes above for details on supported upgrades and upgrade paths.

External vCenter versions 'Minimum' section
The Minimum section in External vCenter versions details the minimum supported vCenter build that is used with a VxRail release.

Typically, upgrade the vCenter version to at least the minimum version before installing or upgrading to the required VxRail release.

Note: Dell EMC strongly recommends using the vCenter builds noted in the Recommended section. These later releases may include security fixes or additional functionality which are not present in the build noted in the Minimum section. The minimum supported version may expose the environment to risks that are not present in the Recommended releases.

External vCenter versions 'Recommended' section
The Recommended section in External vCenter versions details the recommended vCenter builds for use within a VxRail release.

If a version mentions a build number or later, then it means all later builds of that major version are supported (exceptions will be documented).

For example:    
"6.5 U1g or later" would imply 6.5 U1g is the minimum but all later external vCenter builds whether they be 6.5 U1, 6.5 U2, 6.5 U3 and so on are also supported.

Essentially all external vCenter builds of 6.5 later than 6.5 U1g are supported.

Note: A statement such as "6.5 U1g or later" does not imply another major version of vCenter such as 6.7 is automatically supported. Each vCenter major version has its own list of support versions for a VxRail Release.


Notes for specific VxRail Releases
This section will cover any notes (highlighted by a subscript number) associated with a VxRail release.

Article Properties


Affected Product

VxRail Appliance Series

Product

VxRail Appliance Family, VxRail Appliance Series, VxRail Software

Last Published Date

25 Feb 2021

Version

9

Article Type

How To

Rate This Article


Accurate
Useful
Easy to Understand
Was this article helpful?

0/3000 characters