AppSync:AppSync 4.4へのアップグレード後にリモートCLIログインが失敗する

Summary: AppSync 4.4にアップグレードした後、リモートCLIからAppSyncサーバーにログインすると、次のエラーで失敗します。ERROR: Failed to authenticate USERNAME. これは、AppSync CLIを使用する場合の手動ログインとスクリプト化されたログインに影響します。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

AppSync 4.4にアップグレードした後、リモートCLIからAppSyncサーバーにログインすると、次のエラーで失敗します。
ERROR: Failed to authenticate USERNAME

これは、ユーザーがアクティブにログインしているCLIに影響し、AppSyncサーバーにログインするスクリプトにも影響します。

AppSyncサーバー上のデフォルトCLIの場所からAppSyncにログインすると機能します。AppSyncサーバー上のデフォルトの場所は次のとおりです。
C:\EMC\AppSync\appsync-cli

Cause

AppSyncサーバー上のアップグレードされたCLIが、リモートCLIホストが存在するリモート ホストに正しくコピーされませんでした。『Dell EMC AppSync 4.4 User and Administration Guide』の第3章を参照してください。

Resolution

リモートCLIは、『Dell EMC AppSync 4.4 User and Administration Guide』の「Chapter 3: AppSync CLI Utility」(22ページ)に記載されている手順を使用してアップデートする必要があります(以下で引用)。 
 
AppSync CLIユーティリティー
AppSync CLIはAppSyncに付属のユーティリティーで、コマンド ライン インターフェイスからタスクのスクリプト作成や実行を行うために使用します。
AppSync CLIは、EMC\AppSync\appsync-cliディレクトリーにインストールされます。実行するには、Windowsではappsync-cli.batファイルを使用します。

UNIXからAppSync CLIを使用する場合は、次の手順に従います。
1.\EMC\AppSync\appsync-cliディレクトリーをUNIXホストにコピーします。
2.dos2unix appsync-cli.shを実行します。
3.chmod +x appsync-cli.shを使用して実行権限を提供します。これで、appsync-cli.shを使用してすべてのCLIタスクを実行できるように
なりました。

 
前提条件
  • Java Runtime Environment (JRE) version 11 - must be installed and available in path.
  • OpenJDKランタイム環境18.9(ビルド11.0.13+8)
  • 登録済みリソースを使用して構成されたAppSyncインストール
  • 登録済みホストで検出されたアプリケーション
  • 構成済みのサービス プラン
  • 英語以外のホストでCLIを使用している場合は、実行する前に正しいコード ページを設定していることを確認する(コード ページを設定するには、コマンド プロンプトでchcpを使用)

Products

AppSync, AppSync
Article Properties
Article Number: 000196979
Article Type: Solution
Last Modified: 11 Aug 2022
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.