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Headsets Detection Issue on Inspiron and Vostro Notebook and Desktop

Summary: This article provides information about Headset detection issues on your Dell computer.

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Article Content


Symptoms

The computer with Cirrus Audio solution may encounter headsets detection issue. 

When you use a 3.5mm jack headset with a microphone switch which to unmute or mute mode. Some headset device microphone functions cannot be detected and are not workable on the computer when the switch is turned to MUTE.

Mic Switch turns Unmute. Should be detected as headset successfully.
Mic Switch turns Mute. It might be not detected correctly (the Headsets status possible to be headphone, headset, or undetected by different headsets).

Affected Platforms:

Notebooks:

  • Inspiron 3501
  • Inspiron 3505
  • Vostro 3400
  • Vostro 3401
  • Vostro 3405
  • Vostro 3500
  • Vostro 3501
Desktop:
  • Inspiron 3020
  • Inspiron 3910
  • Vostro 3020 T
  • Vostro 3020 SFF
  • Vostro 3910
  • Vostro 3710

Affected Audio Chipset:

  • Cirrus Logic High Definition Audio codec

Affected Device: 

  • A 3.5mm jack headset with microphone switch which to unmute or mute mode
    Headset unmute and mute switch.png
    Figure.1 Headset unmute and mute switch
  • A 3.5mm jack headset with separated microphone part
    Separated microphone part.png
    Figure.2 Separated microphone part

 

Cause

Cirrus Audio codec voltage threshold detection limitation.


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Resolution

Warning: This is not a hardware issue, do not replace any hardware.
 

Go to check the audio codec device ID to identify the audio vendor in the Device Manager

Cirrus Logic High Definition Audio: VEN_1013&DEV_8409 (See Figure.3)

VEN_1013&DEV_8409.png

Figure.3 VEN_1013&DEV_8409

Download and update the Audio Driver to the most recent release from Dell e-support to solve this issue.

Steps:

Update the Intel Cirrus Logic High Definition Audio Driver to the most recent release (revision Version 6.6001.4.12 or later).

  1. Browse to the Dell Drivers & Downloads webpage.
  2. Select the affected computer model.
  3. Select the Operating System that is installed on the Dell computer.
  4. Under Category, select Audio.
  5. Locate the latest Audio Driver.
  6. Click Download and save the file to your computer.
  7. Open File Explorer and browse to the location where the downloaded file is saved.
  8. Double-click the download setup file and follow the on-screen instructions to complete the installation process.
Caution: Do not turn off your computer or disconnect from the power source while updating.

Article Properties


Affected Product

Inspiron 3501, Inspiron 3505, Inspiron 3020 Desktop, Inspiron 3910, Vostro 3400, Vostro 3401, Vostro 3405, Vostro 3500, Vostro 3501, Vostro 3020 Tower Desktop, Vostro 3020 Small Desktop, Vostro 3710, Vostro 3910

Last Published Date

23 Feb 2023

Version

7

Article Type

Solution