Connectrix MDS upgrade returns message "Pre-upgrade check failed "Return code -1."
Summary: When performing Connectrix MDS upgrade, the "install all" command returns the message "Pre-upgrade check failed. "Return code -1."
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
On attempt to run "install all" command, the switch returns the message "Pre-upgrade check failed. "Return code -1."
No indications of what is wrong, md5sum of the firmware files are good. Enough space on the bootflash: and also on the standby supervisor but still the "install all" command fails with "Return code -1."
No indications of what is wrong, md5sum of the firmware files are good. Enough space on the bootflash: and also on the standby supervisor but still the "install all" command fails with "Return code -1."
Cause
The command
runs fine.
The command
(This is the same message as the "install all" command.)
"show incompatibility-all system bootflash:m9700-sf2ek9-xxxx.bin"
runs fine.
The command
"show install all impact kickstart bootflash:m9700-sf2ek9-kickstart-mz.xxxx.bin system bootflash:m9700-sf2ek9-mz.xxxx.bin" fails with "Return code -1."
(This is the same message as the "install all" command.)
Resolution
Workaround:
- Perform a "system switchover" command to failover to the second supervisor. Wait until the command completes. Use the command "show system redundancy status" to confirm the action completes.
- Perform a second "system switchover" command to go back to the previously active supervisor where the upgrade code currently resides.
- Rerun the "install all" command and upgrade should complete.
Affected Products
Connectrix MDS-9710-V2, Connectrix MDS-Series Firmware 8.XProducts
Connectrix MDS-9506, Connectrix MDS-9509, Connectrix MDS-9513, Connectrix MDS-9706, Connectrix MDS-9706-V2, Connectrix MDS-9710, Connectrix MDS-9718, Connectrix MDS-9718-V3Article Properties
Article Number: 000197811
Article Type: Solution
Last Modified: 10 Sep 2025
Version: 6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.