Symptoms
Un sistema de archivos que no tiene espacio en términos de capacidad se queda sin inodos y no puede realizar nuevas escrituras.
Para este problema, no se muestra ningún error en la interfaz de usuario de PowerStore Manager y no se crea ninguna alerta para el sistema de archivos en cuestión.
Las cuotas de usuario y de árbol tampoco se superan.
Los mensajes de error en el lado del cliente pueden incluir, entre otros:
mkdir: cannot create directory 'DirectoryName': Invalid argument |
Es posible que la comprobación del espacio libre mediante df -h aún informe sobre el espacio libre en el recurso compartido de archivos; sin embargo, df -i muestra el uso del inodo del recurso compartido.
En este ejemplo, PowerStoreShare1 tiene una gran cantidad de inodos libres; sin embargo, PowerStoreShare2 está fuera de los inodos.
[user@ ~]$ df -i Filesystem Inodes IUsed IFree IUse% Mounted on ... NAS_Server:/PowerStoreShare1 16889584 35 16889549 1% /MountPath1 NAS_Server:/PowerStoreShare2 16889584 16889584 0 100% /MountPath2 |
Cause
Es posible que el sistema de archivos se haya quedado sin inodos y ya no permita las escrituras en el sistema de archivos.
Un inodo representa metadatos que se utilizan para la estructura de directorios de archivos y carpetas.
Esto no está directamente relacionado con la capacidad (espacio) utilizada.
Según el patrón de uso, los inodos se pueden utilizar, y es posible que PowerStoreOS versión 2.1 y anteriores no puedan replanificar inodos liberados para escrituras adicionales.
Resolution
Corregir
Este problema se resuelve en PowerStoreOS versión 3.0 y posteriores.
Solución alternativa:
Aumente el tamaño del sistema de archivos. La asignación de inodos es automática y se produce en fragmentos de 256 MB. Por lo general, es suficiente para aumentar el espacio del sistema de archivos en unos pocos GB.
Después de restaurar el acceso de escritura, el sistema de archivos se puede reducir al tamaño original nuevamente.
Si el aumento del tamaño del sistema de archivos no resuelve el problema, comuníquese con el soporte técnico de Dell o con su representante de servicio autorizado y mencione este ID de artículo de la base de conocimientos.