AppSync: Unable to create a service plan completion report using AppSync GUI

Summary: Unable to export a service plan completion report using AppSync GUI.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Unable to export a service plan completion report using AppSync 4.5 GUI.

If "Include table headers" is selected and "Export only selected rows" is NOT selected, downloading would not happen. Actually, nothing happened.
SERVICE_PLAN_COMPLETION_REPORT.png

If both "Include table headers" and "Export only selected rows" are selected, downloading started and CSV file was downloaded. However, all data was missing.
SERVICE_PLAN_COMPLETION_REPORT-2.png

CSV.png

Cause

This is an AppSync UI bug.

Resolution

Workaround:
The following AppSync CLI command can be used to export a service plan completion report.
 
appsync-cli.bat -report report_type=spc detailed=true

Sample command output:
C:\EMC\AppSync\appsync-cli>appsync-cli.bat -report report_type=spc detailed=true
Picked up JAVA_TOOL_OPTIONS: "-Dos.name=Windows Server 2019"

Exporting SPC Details to: "C:\EMC\AppSync\Service_Plan_Completion_Report_2022_12_26_18_24_38.csv"

Service_Plan_Completion_Report_2022_12_26_18_24_38.csv
CSV_good.png


Permanent fix:
This issue is expected to be resolved in the version following 4.5.

Additional Information

Refer to the release notes of the version following 4.5 to determine if the fix has been included.

Affected Products

AppSync
Article Properties
Article Number: 000206985
Article Type: Solution
Last Modified: 15 May 2023
Version:  3
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