PowerStore: Nahrání certifikátu pro správu HTTP podepsaného veřejnou infrastrukturou veřejných klíčů se nezdaří
Summary: Při nahrání podepsaného certifikátu do zařízení PowerStore dojde k chybám: Aktualizace certifikátu v úložišti přihlašovacích údajů se nezdařila. Ověřte řetěz certifikátů (0xE09010010013) a zjistíte, že certifikát neobsahuje síť SAN s IP adresou nebo názvem DNS (0xE090A0010009). ...
Symptoms
Failed to update certificate in credential store. Please verify your certificate chain (0xE09010010013).
Certificate does not contain SAN with IP address or DNS name (0xE090A0010009).
Obrázek chyby 0xE09010010013:
Obrázek chyby 0xE090A0010009:
Cause
Pokud jde o PKI, obecně nepovolují IP adresy v síti SAN pro veřejné certifikáty. Veřejná infrastruktura veřejných klíčů obvykle vydává certifikáty, které jsou určené pro veřejné domény nebo webové servery.
Privátní infrastruktura veřejných klíčů je obvykle schopna generovat certifikáty pomocí sítě SAN, které zahrnují libovolný počet adres IPv4, adres IPv6 a plně kvalifikovaných názvů domén (FQDN). Jsou určeny k poskytování certifikačních služeb interně v organizaci (intranet), nikoli veřejnosti (Internet).
Resolution
Ověřte, zda síť SAN obsahuje IPv4 adresu clusteru, IPv6 adresu a název DNS zařízení PowerStore.
Tyto informace najdete pomocí jedné z následujících metod:
- V nástroji Microsoft Certificate Utility:
.crt nebo .pem prodloužení. V příkazovém řádku nebo Powershellu použijte příkaz certutil.exe:
certutil.exe -dump CertificateName.pem
- V prostředí Linuxu pomocí OpenSSL:
openssl x509 -in certificateName.pem -text -noout
Pokud síť SAN neobsahuje všechna tři povinná pole, obraťte se na poskytovatele certifikátů a požádejte o podpis certifikátu a ujistěte se, že obsahuje všechny požadované informace. Pokud nemohou poskytnout certifikát s těmito informacemi, musíte tyto certifikáty vygenerovat prostřednictvím poskytovatele privátní infrastruktury veřejných klíčů nebo vytvořit místní infrastrukturu veřejných klíčů, která může tyto certifikáty podepisovat.
Pokud problémy přetrvávají a všechny informace o certifikátu vypadají správně, můžete se obrátit na podporu společnosti Dell , která vám s problémem certifikátu pomůže.