PowerFlex: Error: Comando fallido de MDM. Estado: Sesión no válida.

Resumen: No se puede ejecutar el comando ScaleIO, error: "Comando fallido de MDM. Estado: Sesión no válida: inicie sesión e inténtelo de nuevo".

Este artículo se aplica a: Este artículo no se aplica a: Este artículo no está vinculado a ningún producto específico. En este artículo no se identifican todas las versiones de los productos.

Síntomas

Cuando se intenta ejecutar un comando desde el administrador de metadatos primarios (MDM), los comandos de PowerFlex fallan con una sesión no válida:

# scli --mdm_ip  --login --username admin
Enter password:
Logged in. User role is Administrator. System ID is XXXXXXXXX

# scli --mdm_ip  --query_all_volumes
Error: MDM failed command. Status: Invalid session. Please login and try again.

Causa

El problema que hace que el MDM rechace las conexiones es que el usuario de CallHome "Monitor" vuelve a iniciar sesión cada diez minutos y no cierra la sesión. Esto hace que las sesiones de inicio de sesión de los usuarios se acumulen y llenen la tabla de sesiones antes de que el tiempo de espera agotado pueda expulsarlas.

Resolución

Elimine (o comente) las siguientes dos líneas en mdm/cfg/conf.txt, en ambos MDM:

user_session_hard_timeout_secs=86400 

user_session_timeout_secs=28800 Stop CallHome service temporarily

 

/opt/emc/scaleio/callhome/bin/delete_service.sh

Reinicie el servicio de MDM:

pkill mdm

Espere 10 minutos y, a continuación, intente emitir scli después de iniciar sesión e iniciar el servicio Call Home nuevamente.

./opt/emc/scaleio/callhome/bin/create_service.sh

Información adicional

El error también puede ocurrir si se agota el tiempo de espera de la sesión de la CLI de ScaleIO.

Productos afectados

PowerFlex Software

Productos

PowerFlex Software
Propiedades del artículo
Número de artículo: 000065938
Tipo de artículo: Solution
Última modificación: 08 ene 2026
Versión:  6
Encuentra las respuestas que necesitas con la ayuda de otros usuarios de Dell
Servicios de asistencia
Comprueba si tu dispositivo está cubierto por los servicios de asistencia.