Dell Unity: Código de error de recolección de datos: 0x6400ba2 (corregible por Dell)
Resumen: La recolección de datos muestra errores "La tarea de servicio no se puede realizar porque hay una tarea de servicio del mismo tipo en curso. Vuelva a intentarlo más tarde. (Código de error: 0x6400ba2)" La recolección de datos de Unity no se completa. (Corregible por Dell) ...
Síntomas
No se generan recopilaciones diarias después de la actualización.
El usuario recibe el siguiente error cuando inicia una nueva recolección de datos desde la interfaz de usuario:
The service task cannot be performed because a service task of same type is in progress. Please retry later. (Error Code:0x6400ba2)

Causa
Si observamos los casos anteriores, si el usuario cree que está tardando más en completar la recolección de datos, entonces el usuario puede salir de la recolección de datos presionando ctrl+c , lo que puede provocar la creación de archivos bloqueados y dejarlos en un estado obsoleto en el sistema.
La existencia de /tmp/dc_service.lock en el archivo /tmp impedía que se ejecutara la recolección de datos.
Resolución
Pasos de solución de problemas realizados para confirmar el problema:
La recolección de datos comenzó a ejecutarse, pero finalmente el trabajo falló con el siguiente error en la interfaz de usuario:
The service action has timeout. (Error Code:0x6400c05)
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Proporcione el resultado del siguiente comando desde ambos SP.
ps -ef | grep svc_dc
Ejemplo de salida:
16:44:29 root@APMXXXXXXXXXXX spa:~# ps -ef |grep svc_dc root 2898 1 0 Feb14 ? 00:00:00 /bin/sh /EMC/Platform/bin/svc_dc -n upgrade_ 5 --skipUpgradeCheck root 3558 2898 0 Feb14 ? 00:00:00 flock --timeout=0 /tmp/dc_service.lock /EMC/Platform/bin/dc_scripts/svc_dc_agent.sh -n upgrade_ 5 root 3562 3558 0 Feb14 ? 00:00:00 /bin/sh /EMC/Platform/bin/dc_scripts/svc_dc_agent.sh -n upgrade_ 5 root 4809 4800 0 Feb14 ? 00:00:00 /bin/sh /EMC/Platform/bin/dc_scripts/svc_dc_core_dump_sweeper.sh root 4830 4809 0 Feb14 ? 00:00:00 /EMC/Platform/bin/dc_grp [DC sweeper group]: /EMC/Platform/bin/dc_scripts/svc_dc_core_dump_sweep_helper.sh 2>&1 | /EMC/Platform/bin/dc_scripts/write_file.sh /EMC/Platform/tmp/dc_dump_sweeper_log.txt root 4833 4830 0 Feb14 ? 00:00:00 sh -c /EMC/Platform/bin/dc_scripts/svc_dc_core_dump_sweep_helper.sh 2>&1 | /EMC/Platform/bin/dc_scripts/write_file.sh /EMC/Platform/tmp/dc_dump_sweeper_log.txt root 4837 4833 0 Feb14 ? 00:55:00 /bin/sh /EMC/Platform/bin/dc_scripts/svc_dc_core_dump_sweep_helper.sh root 5528 4837 0 Feb14 ? 00:20:04 /bin/sh /EMC/Platform/bin/dc_scripts/svc_dc_core_dump_sweep_helper.sh root 6122 6115 0 Feb14 ? 00:57:30 /bin/bash /EMC/Platform/bin/dc_scripts/svc_dc_listener.sh root 12090 11892 0 16:44 pts/0 00:00:00 grep --color=auto svc_dc root 12486 12484 0 15:57 ? 00:00:03 /bin/sh /EMC/Platform/bin/svc_dc --remote-tmp-dir /EMC/Platform/tmp/dcsparse/mnt --remote --no-audit
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Compruebe la existencia de
/tmp/dc_service.locken ambos SP y proporcione una lista del contenido de la carpeta /tmp al soporte de Dell.list the files and check for dc_service.lock on both the sp's 10:16:07 root@CKM0019XXXXXXX spb:~# ls -latr /tmp drwxrwxrwt 2 root root 1024 Apr 26 21:02 .ICE-unix drwxrwxrwt 2 root root 1024 Apr 26 21:02 .Test-unix drwxrwxrwt 2 root root 1024 Apr 26 21:02 .X11-unix drwxrwxrwt 2 root root 1024 Apr 26 21:02 .XIM-unix -rw------- 1 root root 5 Apr 26 21:03 csxid48zogC -rw------- 1 root root 6 Apr 26 21:03 csxidAQ6zuW -rw------- 1 root root 6 Apr 26 21:03 csxidQVAbuk -rw------- 1 root root 6 Apr 26 21:03 csxpidB0riMr -rw------- 1 root root 6 Apr 26 21:03 csxpidPTTm_T -rw------- 1 root root 6 Apr 26 21:03 csxpidTCULQM -rw------- 1 root root 6 Apr 26 21:03 csxpidhXbyNB -rwx------ 1 root root 1288656 May 6 10:15 dc_service.lock <---Need to check with an L2 and remove the file -rw-r--r-- 1 root root 57 Apr 26 21:05 ipv4_conf -rw-r--r-- 1 root root 17 Apr 26 21:05 ipv6_conf -rw-r--r-- 1 root root 0 Apr 26 21:05 vvnx-disc-local-lock.SyncClusterLock -rw-r--r-- 1 root root 0 Apr 26 21:05 vvnx-disc-lock.SyncClusterLock
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Solicite al soporte de Dell que verifique el estado de la recolección de datos e intente finalizar la sesión de recolección de datos actual si hay alguna en ejecución.
# svc_dc --status
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Compruebe la partición raíz en ambos SP:
df -kh 10:16:16 root@CKM0019XXXXXXX spb:/tmp# df -kh Filesystem Size Used Avail Use% Mounted on udev 1.3G 8.0K 1.3G 1% /dev /dev/mapper/alteroot 13G 6.4G 5.8G 53% / tmpfs 4.3G 82M 4.2G 2% /dev/shm tmpfs 4.3G 475M 3.8G 11% /run tmpfs 4.3G 0 4.3G 0% /sys/fs/cgroup /dev/ram0 59M 2.7M 56M 5% /tmp /dev/sda7 128G 1.3G 121G 2% /cores /dev/sda1 113M 1.9M 105M 2% /mnt/c4lx-cfg_msata /pramfs 122M 36M 87M 30% /pramfs /dev/mirrora5 57G 1.3G 53G 3% /EMC/backend/service -
Después de obtener todos los resultados anteriores, comuníquese con el L2 de soporte de Dell para interrumpir el proceso y eliminar el archivo de bloqueo de servicio. Si la recolección de datos no se ejecuta después de
svc_dc --terminateEl soporte abre un ticket con el departamento de ingeniería de Dell.