Data Domain: Dischi segnalati come "esterni"

Riepilogo: Questo articolo spiega perché i dischi vengono visualizzati in uno stato Foreign nei sistemi Data Domain e fornisce i passaggi necessari per risolvere la condizione senza rischiare di perdere i dati. ...

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

  • Uno o più dischi mostrano uno stato esterno nel sistema.
  • Questa condizione può verificarsi dopo:
    • Sostituzione dello chassis (unità principale)
    • Upgrade dei controller
    • Aggiunta di un alloggiamento di espansione precedentemente appartenente a un altro sistema

Si applica a:

  • Tutti i sistemi Data Domain
  • Tutte le versioni di DDOS

Causa

Un disco entra in uno stato Foreign quando contiene dati del file system Data Domain validi provenienti da un altro sistema.
Questo è progettato per evitare sovrascritture accidentali e garantire che i dati vengano gestiti in modo sicuro.

Gli scenari più comuni includono:

  • Sostituzione dello chassis o del controller
  • Upgrade dell'unità principale
  • Spostamento di un alloggiamento da un sistema a un altro
  • Aggiunta di un alloggiamento che non è stato rimosso correttamente dal sistema originale
⚠️Avviso: NON eseguire disk unfail su dischi esterni. Ciò causa la perdita di dati.

Risoluzione

Confermare che il disco o i dischi vengono riportati come Foreign identificando lo stato del disco utilizzando il comando CLI: #disk show state (vedere Tipi di stato del disco nell'articolo della Knowledge Base: Data Domain: Come identificare e risolvere gli stati del disco


  1. Se le unità sono Foreign dopo una sostituzione dello chassis o un aggiornamento del controller
    • La colonna Foreign lo stato è normale dopo uno scambio dello chassis in cui l'headswap è stato eseguito nel menu "System Misconfigured". 
    • Seguire le istruzioni riportate nella documentazione relativa alla sostituzione dello chassis o alla Guida all'upgrade del controller
      • #system headswap Potrebbe essere richiesto un comando: questo porta il numero di serie della scheda principale alle unità, consentendone l'utilizzo da parte del sistema.
    • Una volta completato correttamente l'headswap, i dischi "foreign" passano allo stato "in-use"

Se i dischi vengono segnalati come esterni dopo l'aggiunta di un alloggiamento di espansione: 

  • Ciò si verifica quando un alloggiamento è stato precedentemente collegato a un altro sistema DD e non è stato rimosso in modo pulito.

    Per aggiungere l'enclosure in modo sicuro:

  • Per aggiungere l'enclosure al nuovo sistema, le unità nell'enclosure devono essere in un Ricambio oppure Unknown Stato: 
    • Abbinare il numero di serie dell'enclosure al Foreign Unità.
      • Eseguire il comando #enclosure show summary per individuare il numero di serie dell'enclosure. 
      • Quindi eseguire il comando #disk show state e assicurarsi che le unità che segnalano Foreign si trovano nel nuovo enclosure prima di procedere.
      • Se non corrispondono, NON procedere con i passaggi successivi in quanto potrebbe causare la perdita di dati.
    • A prova di errore (# disk unfail n.n) tutte le unità nell'enclosure aggiunto una alla volta per impostarle su un Spare Stato.
    • Quindi esegui #disk show state per verificare che le unità siano Ricambio.
    • Aggiungere l'enclosure al sistema.

Nota: Se il problema persiste dopo aver eseguito i passaggi descritti in questo articolo, contattare il fornitore di supporto a contratto, raccogliere un pacchetto di supporto e creare una richiesta di assistenza

Informazioni aggiuntive

Prodotti interessati

Data Domain

Prodotti

Data Domain
Proprietà dell'articolo
Numero articolo: 000031955
Tipo di articolo: Solution
Ultima modifica: 20 gen 2026
Versione:  4
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.