L'aggiornamento di Connectrix MDS restituisce il messaggio "Pre-upgrade check failed "Return code -1".

Riepilogo: Quando si esegue l'aggiornamento di Connectrix MDS, il comando "install all" restituisce il messaggio "Pre-upgrade check failed. "Return code -1".

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

Quando si tenta di eseguire il comando "install all", lo switch restituisce il messaggio "Pre-upgrade check failed. "Return code -1".

Nessuna indicazione dell'errore, i valori md5sum dei file del firmware sono validi. Spazio sufficiente in bootflash: e anche sul supervisor di standby, ma il comando "install all" continua a generare l'errore "Return code -1".

Causa

Il comando
"show incompatibility-all system bootflash:m9700-sf2ek9-xxxx.bin"

 funziona correttamente.

Il comando
 "show install all impact kickstart bootflash:m9700-sf2ek9-kickstart-mz.xxxx.bin system bootflash:m9700-sf2ek9-mz.xxxx.bin" fails with "Return code -1."

(stesso messaggio del comando "install all").

Risoluzione

Soluzione alternativa:
  1. Eseguire un comando "system switchover" per eseguire il failover sul secondo supervisor. Attendere il completamento del comando. Utilizzare il comando "show system redundancy status" per verificare il completamento dell'azione.
  2. Eseguire un secondo comando "system switchover" per tornare al supervisor precedentemente attivo in cui risiede attualmente il codice di aggiornamento. 
  3. Eseguire nuovamente il comando "install all" e l'aggiornamento dovrebbe completarsi.

Prodotti interessati

Connectrix MDS-9710-V2, Connectrix MDS-Series Firmware 8.X

Prodotti

Connectrix MDS-9506, Connectrix MDS-9509, Connectrix MDS-9513, Connectrix MDS-9706, Connectrix MDS-9706-V2, Connectrix MDS-9710, Connectrix MDS-9718, Connectrix MDS-9718-V3
Proprietà dell'articolo
Numero articolo: 000197811
Tipo di articolo: Solution
Ultima modifica: 10 set 2025
Versione:  6
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.