Avamar: Problém Tomcat – Aplikace Client Manager není přístupná. Změny provedené v souboru server.xml nejsou trvalé.

Riepilogo: Změny se provádějí v souboru server.xml, ale restartování služby tomcat vrátí změny. Tento článek databáze znalostí také popisuje, kde není přístupná služba tomcat, protože port 8509 naslouchá na verzi 127.0.0.1. ...

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

Tomcat byla v provozu, ale webová stránka AAM (Client Manager) není přístupná: 
Chyba
Protokol /var/log/apache2/mod_jk.log zobrazuje chybu při připojování k portu 8509.
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [info] jk_open_socket::jk_connect.c (758): connect to 127.0.0.1:8509 failed (errno=111)
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [info] ajp_connect_to_endpoint::jk_ajp_common.c (1019): Failed opening socket to (127.0.0.1:8509) (errno=111)
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [error] ajp_send_request::jk_ajp_common.c (1663): (cas) connecting to backend failed. Tomcat is probably not started or is listening on the wrong port (errno=111)
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [info] ajp_service::jk_ajp_common.c (2673): (cas) sending request to tomcat failed (recoverable), because of error during request sending (attempt=1)
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [info] jk_open_socket::jk_connect.c (758): connect to 127.0.0.1:8509 failed (errno=111)
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [info] ajp_connect_to_endpoint::jk_ajp_common.c (1019): Failed opening socket to (127.0.0.1:8509) (errno=111)
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [error] ajp_send_request::jk_ajp_common.c (1663): (cas) connecting to backend failed. Tomcat is probably not started or is listening on the wrong port (errno=111)
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [info] ajp_service::jk_ajp_common.c (2673): (cas) sending request to tomcat failed (recoverable), because of error during request sending (attempt=2)
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [error] ajp_service::jk_ajp_common.c (2693): (cas) connecting to tomcat failed.
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [info] jk_handler::mod_jk.c (2837): Service error=-3 for worker=cas


Zkroucení na port 8509 do localhost zobrazovalo informace o připojení.
root@testlab:/usr/local/avamar-tomcat/conf/#: curl -kv https://127.0.0.1:8509
* Rebuilt URL to: https://127.0.0.1:8509/
*   Trying 127.0.0.1...
* TCP_NODELAY set
* connect to 127.0.0.1 port 8509 failed: Connection refused
* Failed to connect to 127.0.0.1 port 8509: Connection refused
* Closing connection 0
curl: (7) Failed to connect to 127.0.0.1 port 8509: Connection refused
 


 
 

Causa

Port 8509 neposlouchá adresu localhost.

Risoluzione

1. Přihlaste se k serveru Avamar jako uživatel s oprávněním správce a povznesete oprávnění ke kořenovému uživateli: 

2. Zálohování stávajícího konfiguračního souboru server.xml: 
cp -p /usr/local/avamar-tomcat/conf/server.xml /usr/local/avamar-tomcat/conf/server.xml-orig
cp -p  /usr/local/avamar/etc/server.xml /usr/local/avamar/etc/server.xml-orig

3. Upravte soubory /usr/local/avamar-tomcat/conf/server.xml  a /usr/local/avamar/etc/server.xml a přidejte níže zvýrazněný řádek: 
    
    
     
 
4. Uložte a zavřete soubor. 

5. Restartujte služby tomcat a Apache: 
emwebapp.sh --restart
service apache2 restart
 
 
Proprietà dell'articolo
Numero articolo: 000203109
Tipo di articolo: Solution
Ultima modifica: 14 lug 2023
Versione:  2
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.