Avamar: Tomcat Issue - Client Manager is not accessible. Changes made to server.xml are not persistent
Riepilogo: Changes are made to server.xml, but restarting the tomcat service reverts the changes. This KB also discusses where tomcat is not accessible because port 8509 is not listening on 127.0.0.1. ...
Questo articolo si applica a
Questo articolo non si applica a
Questo articolo non è legato a un prodotto specifico.
Non tutte le versioni del prodotto sono identificate in questo articolo.
Sintomi
Tomcat was up but the AAM (Client Manager) webpage is not accessible:
/var/log/apache2/mod_jk.log shows an error when connecting on port 8509.
Curl to port 8509 to localhost was showing connection refused.
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [info] jk_open_socket::jk_connect.c (758): connect to 127.0.0.1:8509 failed (errno=111)
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [info] ajp_connect_to_endpoint::jk_ajp_common.c (1019): Failed opening socket to (127.0.0.1:8509) (errno=111)
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [error] ajp_send_request::jk_ajp_common.c (1663): (cas) connecting to backend failed. Tomcat is probably not started or is listening on the wrong port (errno=111)
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [info] ajp_service::jk_ajp_common.c (2673): (cas) sending request to tomcat failed (recoverable), because of error during request sending (attempt=1)
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [info] jk_open_socket::jk_connect.c (758): connect to 127.0.0.1:8509 failed (errno=111)
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [info] ajp_connect_to_endpoint::jk_ajp_common.c (1019): Failed opening socket to (127.0.0.1:8509) (errno=111)
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [error] ajp_send_request::jk_ajp_common.c (1663): (cas) connecting to backend failed. Tomcat is probably not started or is listening on the wrong port (errno=111)
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [info] ajp_service::jk_ajp_common.c (2673): (cas) sending request to tomcat failed (recoverable), because of error during request sending (attempt=2)
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [error] ajp_service::jk_ajp_common.c (2693): (cas) connecting to tomcat failed.
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [info] jk_handler::mod_jk.c (2837): Service error=-3 for worker=cas
Curl to port 8509 to localhost was showing connection refused.
root@testlab:/usr/local/avamar-tomcat/conf/#: curl -kv https://127.0.0.1:8509
* Rebuilt URL to: https://127.0.0.1:8509/
* Trying 127.0.0.1...
* TCP_NODELAY set
* connect to 127.0.0.1 port 8509 failed: Connection refused
* Failed to connect to 127.0.0.1 port 8509: Connection refused
* Closing connection 0
curl: (7) Failed to connect to 127.0.0.1 port 8509: Connection refused
Causa
Port 8509 is not listening for the localhost.
Risoluzione
1. Log in to the Avamar server as the admin user and elevate to the root user:
2. Back up the existing server.xml configuration file:
3. Edit /usr/local/avamar-tomcat/conf/server.xml and /usr/local/avamar/etc/server.xml, add the line highlighted below:
4. Save and close the file.
5. Restart tomcat and Apache:
2. Back up the existing server.xml configuration file:
cp -p /usr/local/avamar-tomcat/conf/server.xml /usr/local/avamar-tomcat/conf/server.xml-orig
cp -p /usr/local/avamar/etc/server.xml /usr/local/avamar/etc/server.xml-orig
3. Edit /usr/local/avamar-tomcat/conf/server.xml and /usr/local/avamar/etc/server.xml, add the line highlighted below:
<!-- Define an AJP 1.3 Connector on port 8009 -->
<Connector port="8509" protocol="AJP/1.3" redirectPort="8543" Server="Avamar" secret="AVTOMCATSEC" address="::1" />
<Connector port="8509" protocol="AJP/1.3" redirectPort="8543" Server="Avamar" secret="AVTOMCATSEC" address="127.0.0.1" />
5. Restart tomcat and Apache:
emwebapp.sh --restart
service apache2 restart
Proprietà dell'articolo
Numero articolo: 000203109
Tipo di articolo: Solution
Ultima modifica: 14 lug 2023
Versione: 2
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.