Avamar: Tomcat-Problem – Client Manager ist nicht zugänglich. Änderungen an server.xml sind nicht persistent.
Riepilogo: Änderungen werden an server.xml vorgenommen, aber durch den Neustart des Tomcat-Dienstes werden die Änderungen zurückgesetzt. In diesem Wissensdatenbank-Artikel wird außerdem erläutert, wo Tomcat nicht zugänglich ist, da Port 8509 127.0.0.1 nicht überwacht. ...
Questo articolo si applica a
Questo articolo non si applica a
Questo articolo non è legato a un prodotto specifico.
Non tutte le versioni del prodotto sono identificate in questo articolo.
Sintomi
Tomcat war aktiv, aber auf die AAM-Webseite (Client Manager) kann nicht zugegriffen werden:
/var/log/apache2/mod_jk.log zeigt einen Fehler an, wenn eine Verbindung zu Port 8509 hergestellt wird.
Curl zu Port 8509 zum localhost zeigte an, dass die Verbindung verweigert wurde.
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [info] jk_open_socket::jk_connect.c (758): connect to 127.0.0.1:8509 failed (errno=111)
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [info] ajp_connect_to_endpoint::jk_ajp_common.c (1019): Failed opening socket to (127.0.0.1:8509) (errno=111)
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [error] ajp_send_request::jk_ajp_common.c (1663): (cas) connecting to backend failed. Tomcat is probably not started or is listening on the wrong port (errno=111)
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [info] ajp_service::jk_ajp_common.c (2673): (cas) sending request to tomcat failed (recoverable), because of error during request sending (attempt=1)
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [info] jk_open_socket::jk_connect.c (758): connect to 127.0.0.1:8509 failed (errno=111)
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [info] ajp_connect_to_endpoint::jk_ajp_common.c (1019): Failed opening socket to (127.0.0.1:8509) (errno=111)
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [error] ajp_send_request::jk_ajp_common.c (1663): (cas) connecting to backend failed. Tomcat is probably not started or is listening on the wrong port (errno=111)
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [info] ajp_service::jk_ajp_common.c (2673): (cas) sending request to tomcat failed (recoverable), because of error during request sending (attempt=2)
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [error] ajp_service::jk_ajp_common.c (2693): (cas) connecting to tomcat failed.
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [info] jk_handler::mod_jk.c (2837): Service error=-3 for worker=cas
Curl zu Port 8509 zum localhost zeigte an, dass die Verbindung verweigert wurde.
root@testlab:/usr/local/avamar-tomcat/conf/#: curl -kv https://127.0.0.1:8509
* Rebuilt URL to: https://127.0.0.1:8509/
* Trying 127.0.0.1...
* TCP_NODELAY set
* connect to 127.0.0.1 port 8509 failed: Connection refused
* Failed to connect to 127.0.0.1 port 8509: Connection refused
* Closing connection 0
curl: (7) Failed to connect to 127.0.0.1 port 8509: Connection refused
Causa
Port 8509 überwacht den localhost nicht.
Risoluzione
1. Melden Sie sich beim Avamar -Server als Admin-Benutzer an und erhöhen Sie sie auf den Root-Benutzer:
2. Sichern Sie die vorhandene Server.xml-Konfigurationsdatei:
3. Bearbeiten Sie /usr/local/avamar-tomcat/conf/server.xml und /usr/local/avamar/etc/server.xml und fügen Sie die unten hervorgehobene Zeile hinzu:
4. Speichern und schließen Sie die Datei.
5. Starten Sie Tomcat und Apache neu:
2. Sichern Sie die vorhandene Server.xml-Konfigurationsdatei:
cp -p /usr/local/avamar-tomcat/conf/server.xml /usr/local/avamar-tomcat/conf/server.xml-orig
cp -p /usr/local/avamar/etc/server.xml /usr/local/avamar/etc/server.xml-orig
3. Bearbeiten Sie /usr/local/avamar-tomcat/conf/server.xml und /usr/local/avamar/etc/server.xml und fügen Sie die unten hervorgehobene Zeile hinzu:
5. Starten Sie Tomcat und Apache neu:
emwebapp.sh --restart
service apache2 restart
Proprietà dell'articolo
Numero articolo: 000203109
Tipo di articolo: Solution
Ultima modifica: 14 lug 2023
Versione: 2
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.