Errore di scansione driver della riga di comando di Dell Command Update

Riepilogo: Ulteriori informazioni su Dell Command | Errore di scansione del driver di aggiornamento, "Nessuna informazione di aggiornamento disponibile. Il sistema non è supportato dai cataloghi disponibili." ...

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

Dell Command | L'aggiornamento contiene lo strumento dell'interfaccia della riga di comando (CLI) dcu-cli.exe. Ciò consente agli amministratori di usufruire delle capacità di configurazione di Dell Command | Gestione degli aggiornamenti e dei driver dal prompt dei comandi di Windows o da PowerShell.

La scansione degli aggiornamenti dei driver non riesce e restituisce l'errore "Nessuna informazione sull'aggiornamento disponibile. Il sistema non è supportato dai cataloghi disponibili." Questo errore si verifica quando è in uso un file XML di TechDirect Custom Driver Catalog.

Un esempio di comando che potrebbe non riuscire con questo errore è:
dcu-cli /scan -cataloglocation=C:\temp\CUSTOM_CATALOG.xml

Nessuna informazione sull'aggiornamento

Prodotti interessati:

  • Dell Command | Update

Causa

Questo messaggio di errore è fuorviante, perché i test condotti da Dell dimostrano che il modello utilizzato è supportato. Verificare che il modello sia supportato facendo riferimento a Dell Command | Pagina dei dettagli del driver dell'applicazione aggiornata nel Supporto Dell e facendo riferimento ai Sistemi compatibili.

L'opzione richiesta -allowXML Lo switch è ancora in uno stato disabilitato (predefinito), causando l'errore.

-allowXML: Consente all'utente di abilitare o disabilitare l'utilizzo del file di catalogo XML

Risoluzione

I comandi corretti richiesti per eseguire la scansione con un file XML di TechDirect Custom Driver Catalog in uso sono i seguenti:

  • dcu-cli /configure -allowXML=enable
  • dcu-cli /scan -cataloglocation=C:\temp\CUSTOM_CATALOG.xml

Se il problema persiste, verificare che siano state selezionate le piattaforme Dell corrette durante il processo di creazione del file XML del catalogo driver personalizzato TechDirect.

Informazioni aggiuntive

Per ulteriori informazioni sulla riga di comando, consultare il documento Dell Command | Sezione Aggiornamento dell'interfaccia della riga di comando di Dell Command | Guida di riferimento per l'aggiornamento dal supporto per i manuali e la documentazione di Dell Command Update.

Prodotti interessati

OptiPlex, Latitude, XPS, Fixed Workstations, Mobile Workstations, Dell Command | Update
Proprietà dell'articolo
Numero articolo: 000223721
Tipo di articolo: Solution
Ultima modifica: 25 ago 2025
Versione:  3
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.