「Data Domain:ディスクが「Foreign」として報告される

概要: この記事では、Data Domainシステムでディスクが外部状態で表示される理由について説明し、データ ロスのリスクを冒さずに状態を解決するために必要な手順について説明します。

この記事は次に適用されます: この記事は次には適用されません: この記事は、特定の製品に関連付けられていません。 すべての製品パージョンがこの記事に記載されているわけではありません。

現象

  • 1つまたは複数のディスクが、システム内で 外部 状態を示しています。
  • この状態は、次の後に発生する可能性があります。
    • シャーシ(ヘッド ユニット)の交換
    • コントローラーのアップグレード
    • 以前に別のシステムに属していた拡張シェルフの追加

該当製品:

  • すべてのData Domainシステム
  • すべてのDDOSリリース

原因

別のシステムからの有効なData Domainファイルシステム データが含まれている場合、ディスクは外部 状態になります。
これは、誤って上書きされるのを防ぎ、データを安全に処理するように設計されています。

一般的なシナリオは次のとおりです。

  • シャーシまたはコントローラーのスワップ
  • ヘッドユニットのアップグレード
  • システム間でのシェルフの移動
  • 元のシステムから適切に取り外されなかったシェルフの追加
⚠️警告:実行しない disk unfail 外部ディスク上。これにより、データが失われます。

解決方法

ディスクが次のように報告されていることを確認します 「Foreign」 CLIコマンドを使用してディスクの状態を特定する: #disk show state (KB記事の「ディスク状態のタイプ」を確認してください。「Data Domain:ディスクの状態を特定して解決する方法)


  1. ドライブが 「Foreign」 シャーシ スワップまたはコントローラーのアップグレード後、 
    • 「Foreign」 [System Misconfigured]メニューでヘッド スワップが実行されたシャーシのスワップ後の状態は正常です。 
    • シャーシ交換または コントローラー アップグレード ガイド のマニュアルの手順に従います。 
      • #system headswap コマンドが必要な場合があります。これにより、メインボードのシリアル番号がドライブにプッシュされ、システムで使用できるようになります。
    • ヘッドスワップが正常に完了すると、「外部」ディスクは「使用中」状態に変わります

拡張シェルフを追加した後にディスクが外部として報告される場合: 

  • これは、シェルフが以前に別のDDシステムに接続されていて、適切に取り外されていない場合に発生します。

    エンクロージャを安全に追加するには、次の手順を実行します。

  • エンクロージャを新しいシステムに追加するには、エンクロージャ内のドライブが スペア または 不明 状態: 
    • エンクロージャのシリアル番号を 「Foreign」 ドライブ。
      • 次のコマンドを実行します。 #enclosure show summary をクリックして、エンクロージャのシリアル番号を確認します。 
      • 次に、次のコマンドを実行します #disk show state また、ドライブがレポートしていることを確認します 「Foreign」 続行する前に、新しいエンクロージャ内にあります。
      • 一致しない場合は、データが失われる可能性があるため、次の手順に進まないでください。
    • 失敗しない (# disk unfail n.n) 追加されたエンクロージャ内のすべてのドライブを一度に1つずつ削除して、 「Spare」 状態。
    • Then run #disk show state ドライブが 予備。
    • システムにエンクロージャを追加します

注:この記事の手順を実行しても問題が解決しない場合は、契約しているサポート プロバイダーに連絡し、サポート バンドル(SUB)を収集して、サービス リクエストを作成してください

その他の情報

対象製品

Data Domain

製品

Data Domain
文書のプロパティ
文書番号: 000031955
文書の種類: Solution
最終更新: 20 1月 2026
バージョン:  4
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。