NetWorkerトラブルシューティング ガイド: プロセス クラッシュとコア ダンプ

概要: Dell NetWorkerプロセス クラッシュとコア ダンプのトラブルシューティングに関する包括的なガイド

この記事は次に適用されます: この記事は次には適用されません: この記事は、特定の製品に関連付けられていません。 すべての製品パージョンがこの記事に記載されているわけではありません。

現象

NetWorkerトラブルシューティング ガイド: プロセス クラッシュとコア ダンプ

ビデオ:Dell NetWorkerプロセス クラッシュとコア ダンプのトラブルシューティングに関する包括的なガイド

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原因

NetWorkerプロセスが応答しない理由は多数あります。この記事では、NetWorkerプロセスが応答しない問題を特定して解決するための推奨方法について説明します。

解決方法

メモ: システムのコア ダンプのトラブルシューティングと診断を行う前に、Dellサポート サイトでコア ダンプが発生したプロセスに固有の記事を検索してください。一部のシナリオでは、既知の修正が掲載されています。修正方法が見つからない場合は、この記事に記載されている手順に進みます。考えられる原因を排除し、必要に応じて対応処置を実行するために、各手順またはドキュメントへのリンクが提供されています。問題を特定し、適切な解決策にたどり着けるように、その手順は最も適切な順序で並んでいます。手順をスキップしないでください。

手順1:情報の収集 - 問題の説明:

問題の完全な説明を生成するには、次の質問に答えてください。
  • どのような状況でプロセスがクラッシュしますか。この動作は一貫していますか?
  • 以前はこれでうまくいきましたか?
  • 発生時刻と観察された行動傾向は?
  • この問題は、バックアップ環境、バックアップ、または特定のタイプのバックアップ グループに高負荷のときにのみ発生しますか?
  • 問題が最初に発生したのはいつですか?その後、何が変わりましたか?
  • 問題の範囲(すべてのクライアント/一部のクライアント、すべてのバックアップ ターゲットまたは一部)
  • これまでに修正を試みたことと、そこからどのような結論が導き出されたか。

手順2:情報収集 - 環境

応答していないNetWorkerプロセスと、そのマシン(サーバー、ストレージ ノード、クライアント)を特定します。

手順3:サポート

  • オンラインの 『NetWorker互換性ガイド 』(Dellサポート アカウントへのサインインが必要)を使用して、すべてのコンポーネント(NetWorkerサーバー、ファイル システム バージョン、プロキシ、ストレージ ノード、クライアント、ターゲット)がサポートされていることを確認します。
  • プロセスのクラッシュ(ディスク障害、ディスクの空き容量、ネットワーク エラーなど)の原因となる、基盤となるオペレーティング システムまたはハードウェアの欠陥がないことを確認します。

手順4:ベストプラクティス

NetWorkerパフォーマンス最適化計画ガイド 』には、最適にチューニングされたNetWorker環境をサポートするソフトウェアおよびハードウェアの要件の一覧が記載されています。ベスト プラクティスに従っていることを確認するために、これを確認する必要があります。これは、応答しないプロセスが最も負荷の高いときに発生する場合に関係します。NetWorkerのマニュアルは、次の場所から入手できます。NetWorkerのサポート |ドライバーおよびダウンロード 


手順5:コンポーネントの分離:

プロセスが応答しない問題の根本原因を見つける方法は、ステップ1で定義された動作によって異なります。トリガーが不明な場合は、テストを実行して、クラッシュをトリガーしているものを確認できます。
 

  • 高負荷下でのシステム パフォーマンスの監視
  • 動作の共通性については、クラッシュ時のオペレーティング システムのログ ファイルを調べます。
    • Linuxの場合 /var/log/messages
    • Windowsの場合:システム および アプリケーションのイベントログ
  • NetWorkerログを確認して、コア ダンプが発生したときにどのような操作が発生しているか、また次のタイミングで発生していることを確認します。
  • このマシンで実行されるNetWorker以外の操作で、その動作に影響を与える可能性があるものと、それらのスケジュールがクラッシュの時刻と相関しているかどうかを確認します。
  • クラッシュが繰り返し発生する場合は、一部のパラメーターを変更して原因を絞り込みます。  たとえば、異なるターゲット メディアへのバックアップや、同じNetWorkerクライアントからの異なるタイプのデータのバックアップなどです


手順6:解決策

コアダンプは、特定の瞬間(通常はプログラムが異常終了したとき)にプロセスの作業メモリをキャプチャするファイルです。コア ダンプは、障害発生時に実行中の関数と使用中のデータを明らかにすることで、プロセスが応答しなくなった理由を特定するのに役立ちます。

  1. エラー コードまたはメッセージの診断を支援するため、 /nsr/cores ディレクトリーでUNIXまたはLinuxのNetWorkerプロセスの最近のコア ダンプを検索するか、Windowsレジストリで定義されているクラッシュ ディレクトリーを確認します(手順2を参照)。
  2. 存在しない場合は、プロセス クラッシュが発生した場合にコア ダンプ ファイルを生成するようにオペレーティング システムが設定されていることを確認します。詳細については、オペレーティング システムのマニュアルを参照してくださいが、簡単に言うと、これには変更が含まれます ulimit -c-f UNIXおよびLinuxでの値、およびWindowsでレジストリの変更を行います。
  3. 次のようなオペレーティング システム ツール gdb (UNIXおよびLinux)と WinDbg (Windows)を使用して、コア ダンプを評価できます。これらの機能については、OSベンダーのドキュメントを参照してください。
  4. NetWorkerサポート レビューについては、次を参照してください。NetWorker:pkgcoreを使用してコア ダンプ バンドルを生成する方法(英語)」

その他の情報

コア ダンプ関連のケースでNetWorkerサポートに問い合わせる場合は、この記事に従って収集した情報を提供する必要があります。NSRGETバンドルとコア ダンプ pkgcore バンドルも提供する必要があります。

対象製品

NetWorker

製品

NetWorker
文書のプロパティ
文書番号: 000034716
文書の種類: Solution
最終更新: 23 1月 2026
バージョン:  7
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