Avamar:MCSが「OutOfMemory」メッセージを受信する
概要: 仮想マシンからのNVRAMファイルが大きいため、Avamar管理コンソール サーバー(MCS)が「OutOfMemory」メッセージを受信します。
現象
スケジュール設定されたVMwareバックアップと物理バックアップが応答していないように見えます。
Avamar Administratorの[アクティビティ]ウィンドウには実行中と表示されることがありますが、進行状況のバイト数には変化がありません。
管理コンソール サーバー(MCS)が「メモリー不足」状態を報告し、UIの応答が遅くなる場合があります。
VMwareクライアントは長時間チェックインしません。
原因
仮想マシンのバックアップ中に、MCSは不揮発性ランダム アクセス メモリー(NVRAM)ファイルを仮想マシンにロードします。 javaheap BIOS構成を読み取ります。
NVRAMファイルは、VMwareと同じ場所にあります。 *.vmdk データストア上にあるファイル。
通常はわずか数KB(10 KB未満)のサイズしかないNVRAMファイルが、1 MB前後またはそれを超えるサイズに増加することがあります。
これはMCSを引き起こすのに十分です javaheap メモリが不足します。
解決方法
1.Avamarユーティリティー ノードにログインし、管理者キーをロードします。キーのロード手順については、「 Avamar: Avamarサーバーにログインし、さまざまなキーをロードする方法について説明します。」
2.かどうかを確認します javaheap はすでに1.5 GBに設定されています。次の出力では「-Xmx1536m」と示されています。
ps -elf | grep java | grep mcserver
0 S admin 13623 1 2 76 0 - 556102 - 16:54 pts/0 00:10:16
/usr/java/jre1.6.0_22/bin/java -Xmx1536m -XX:MaxPermSize=256m -server -ea -cp
.:/usr/local/avamar/lib/mcserver.jar:/usr/local/avamar/lib/asn_server.jar:/usr/local/avamar/lib/mail.jar:/usr/local/avamar/lib/activation.jar:/usr/local/avamar/lib/xercesImpl.jar:/usr/local/avamar...<snip>...
6.1.23.jar:/usr/local/avamar/lib/jetty-util-6.1.23.jar:/usr/local/avamar/lib/servlet-api-2.5.jar:/usr/local/avamar/lib/jsp-api-2.1.jar:/usr/local/avamar/lib/jsp-
3.ログに「OutOfMemory」メッセージが報告されているかどうかを確認します(NVRAMが大きい可能性があるため)。
grep -hi "OutOfMemoryError\|VMware" /usr/local/avamar/var/mc/server_log/mcserver.log*
Exception in thread "Thread-191" java.lang.OutOfMemoryError: Java heap space
at java.util.Arrays.copyOf(Unknown Source)
at java.io.ByteArrayOutputStream.write(Unknown Source)
at
com.avamar.mc.vmware.VmwareVirtualMachineFiles.readVmFile(VmwareVirtualMachineFiles.java:386)
at
com.avamar.mc.vmware.VmwareVirtualMachineFiles.getVirtualMachineFile(VmwareVirtualMachineFiles.java:109)
at
com.avamar.mc.vmware.VmwareVirtualCenter.getVirtualMachineFile(VmwareVirtualCenter.java:902)
at
com.avamar.mc.vmware.VmwareService.getNvramFileContent(VmwareService.java:2596)
at com.avamar.mc.wo.JobScheduler._gotVmWork(JobScheduler.java:530)
at com.avamar.mc.wo.JobScheduler.gotVmWork(JobScheduler.java:327)
at com.avamar.mc.wo.DPNScheduler.gotVmWork(DPNScheduler.java:144)
4.大容量NVRAMを搭載したクライアントを確認します。
grep "nvramContent\=\"null\"" mcserver.log.*
次の出力例では、クライアントの「Company_1_Email-PDB reports report」が報告されます。"nvramContent="null"':
FINE: MCS to Client(10.n.n.64:39270) Response: <workorder work="backup" type="work" ack="yes" cid="8580a6233796c72a4a73b89f0d2ae5fb644fcbd0" sync="bg"
wid="NFSSQLCluster-1350439200070" pid="vmimagew" pidnum="3016" msgver="5" sessionid="c61b498fdf57eaca6cadc760a3b7fbf6f7e89aea"
targetCid="bae291d2ba3d3e3ea77d5394bcaa60da3a072463" targetUUID="500faaf4-8f4b-b5f2-1744-1277d19a79cf" vcCid="3a25059a880e1d22b981c5815858d3dc95312621"
time="1350442682" customaction="" ><targetlist><path name="[nas_datastore_03] Company_1_Email-PDB/Company_1_Email-PDB.vmdk" backup="true" diskCapacity="85899345920">
</path><path name="[nas_datastore_03_sqldb] Company_1_Email-PDB/Company_1_Email-PDB.vmdk" backup="true" diskCapacity="171798691840"></path>
<path name="[nas_datastore_03_sqllogs] Company_1_Email-PDB/Company_1_Email-PDB.vmdk" backup="true" diskCapacity="32212254720"></path></targetlist><directives>
<flag type="string" name="encrypt" value="proprietary" /> <flag type="string" name="encrypt-strength" value="cleartext" /> <flag type="string" name="expire"
value="1353034800" /> <flag type="string" name="retention-type" value="daily,weekly,monthly,yearly"
....
"TRUE"scsi0:2.deviceType = "scsi-hardDisk"scsi0:2.present = "TRUE"scsi0:2.redo = ""migrate.hostlog = "
./Company_1_Email-PDB-b5986b60.hlog"scsi0:0.ctkEnabled = "TRUE"ctkEnabled = "TRUE"sched.scsi0:1.shares = "normal"
ethernet1.virtualDev = "vmxnet3"ethernet1.pciSlotNumber = "192"ethernet1.startConnected = "TRUE"
ethernet1.allowGuestConnectionControl = "TRUE"ethernet1.features = "1"ethernet1.wakeOnPcktRcv = "TRUE"
ethernet1.addressType = "vpx"ethernet1.generatedAddress = "00:00:56:8f:3f:b1"ethernet1.networkName = "
VM Network - 117"ethernet1.present = "TRUE"" nvramContent="null" prevBackup="null" snapshotDesired="always" prevSnapName="null" >
</vmInfo><vmDiskInfoList numDisks="3" > <vmDiskInfo capacityInKB="83886080" vmdkFilename="[nas_datastore_03] Company_1_Email-PDB/Comany_1_Email-PDB.vmdk"
vmdkBaseFile="[nas_datastore_03] Company_1_Email-PDB/Comany_1_Email-PDB.vmdk" ordinal="1" srcOrdinal="-1" label="Hard disk 1" diskKey="2000"
datastoreUrl="ds:///vmfs/volumes/e4b3f733-24646679/" datastore="nas_datastore_03"
nvramcontent 値があるため、すべてのインスタンスを確認する必要があります。
5.大容量NVRAMを持つクライアントがログから特定されたら、次の手順を実行します。
ある。クライアントを再起動して、新しいNVRAMファイルを作成します。
B。同じクライアントで問題が発生した場合は、デル・テクノロジーズ テクニカル サポート チームで サービス リクエストを作成し てください。
6.エラー メッセージが引き続き表示される場合は、「 Avamar: 現象コード22402 - 説明: 追加のトラブルシューティングのためにコンソール サーバーのデータをサーバー(解決パス)に保存できませんでした。