Dell Unity: Ein angehaltenes Softwareupgrade kann nicht fortgesetzt oder erneut versucht werden
概要: Ein Dell Unity OE-Upgrade kann nach dem Anhalten möglicherweise nicht fortgesetzt werden, wenn Managementservices zu einem anderen Storage-Prozessor (SP) wechseln als dem, der die Upgradedateien enthält. Starten Sie den aktiven SP neu, sodass der SP, der das Upgrade-Image enthält, zum primären SP wird, und versuchen Sie das Upgrade erneut oder setzen Sie es fort. ...
現象
Das Unity OE-Upgrade wurde angehalten, da die Option Storage-Prozessoren automatisch neu starten nicht ausgewählt wurde. Beim Versuch, das Upgrade fortzusetzen, zeigt die Unisphere-Benutzeroberfläche eine Meldung zum erneuten Laden an und das Upgrade wird nicht fortgesetzt.
service@(none) spa:~$ uemcli -u admin -p xxxxx /sys/soft/upgrade resume Operation failed. Error code: 0x6000cb9 The system encountered an unexpected error while upgrading the software. Reboot your Primary storage processor and try upgrading again. Check System > Logs for related messages. (Error Code:0x6000cb9)
原因
Die Upload-Binärdateien befinden sich im falschen SP. Es gab einen Switchover der Managementservices ab dem Zeitpunkt, an dem das "Upgrade-Image" hochgeladen und der Vorgang "Fortsetzen" versucht wurde.
解決方法
Überprüfen Sie die /EMC/CEM/log/cemtracer.log Datei für Einträge ähnlich den folgenden:
service@(none) spa:/EMC/CEM/log$ grep "papi_get.sh tasks_info" *log cemtracer.log:02 Aug 2017 23:03:36 - [UpdateProvider] FATAL - {0:x:x}[x|x|x][createJob @ ../../../components/providers/osls/UpdateProvider/src/C4CB_SoftwareInstallationService.cpp:1123] createJob exception: Failed to get tasks info: caused by the error in P-API backend (error running 'papi_get.sh tasks_info Unity-4.2.0.9392909.tgz.bin' meta (nil): request error code: 9, command error code: 0x100)
Dieser Fehler weist darauf hin, dass das Upgrade nicht fortgesetzt werden kann, da das System die Informationen zum Upgrade-Task nicht abrufen kann. Dies tritt in der Regel auf, wenn sich die Upgradedateien auf einem SP befinden, während Managementservices auf dem Peer-SP ausgeführt werden. Beispielsweise können sich die Upgradedateien auf SPB befinden, während SPA derzeit die Managementservices hostet. Diese Bedingung kann nach einem SP-Neustart, einem Failover oder einem anderen Ereignis auftreten, das den aktiven SP ändert.
Lösung
Starten Sie den SP neu, auf dem derzeit die Managementservices ausgeführt werden (in diesem Beispiel SPA), sodass der SPB, der die Aktualisierungsdateien (SPB) enthält, wieder zum primären SPB wird. Sobald der richtige SP aktiv ist, sollte der Vorgang zum Wiederaufnehmen oder Wiederholen erfolgreich sein.
Wenn das Problem nach der Durchführung dieser Aktion weiterhin besteht, wenden Sie sich an den technischen Support von Dell und lesen Sie diesen Wissensdatenbank-Artikel.