Dell Unity: keskeytettyä ohjelmistopäivitystä ei voi jatkaa tai yrittää uudelleen

概要: Dell Unity OE -päivitys ei välttämättä jatku keskeytyksen jälkeen, jos hallintapalvelut vaihtavat eri tallennussuorittimeen (SP) kuin siihen, jossa päivitystiedostot ovat. Käynnistä aktiivinen SP uudelleen niin, että päivityskuvan sisältävästä SP:stä tulee ensisijainen, ja yritä sitten päivitystä uudelleen tai jatka sitä. ...

この記事は次に適用されます: この記事は次には適用されません: この記事は、特定の製品に関連付けられていません。 すべての製品パージョンがこの記事に記載されているわけではありません。

現象

Unity OE -päivitys keskeytetään, koska Automatically Reboot Storage Processors -asetusta ei ollut valittu. Kun yrität jatkaa päivitystä, Unisphere-käyttöliittymä näyttää uudelleenlatausviestin, eikä päivitys jatku.

service@(none) spa:~$ uemcli -u admin -p xxxxx /sys/soft/upgrade resume

Operation failed. Error code: 0x6000cb9
The system encountered an unexpected error while upgrading the software. Reboot your Primary storage processor and try upgrading again. Check System > Logs for related messages. (Error Code:0x6000cb9)

原因

Latausbinaarit ovat väärässä SP:ssä. Hallintapalvelut siirtyivät heti, kun päivitysnäköistiedosto ladattiin ja jatkamistoimintoa yritettiin.

解決方法

Tarkista /EMC/CEM/log/cemtracer.log tiedosto seuraavanlaisista merkinnöistä:

service@(none) spa:/EMC/CEM/log$ grep "papi_get.sh tasks_info" *log
cemtracer.log:02 Aug 2017 23:03:36  - [UpdateProvider] FATAL - {0:x:x}[x|x|x][createJob @ ../../../components/providers/osls/UpdateProvider/src/C4CB_SoftwareInstallationService.cpp:1123] createJob exception: Failed to get tasks info: caused by the error in P-API backend (error running 'papi_get.sh tasks_info Unity-4.2.0.9392909.tgz.bin' meta (nil): request error code: 9, command error code: 0x100)

Tämä virhe ilmaisee, että päivitystä ei voi jatkaa, koska järjestelmä ei pysty hakemaan päivitystehtävän tietoja. Tavallisesti näin käy, kun päivitystiedostot sijaitsevat yhdessä SP:ssä, kun taas hallintapalvelut ovat käynnissä vertaispalvelussa. Päivitystiedostot voivat esimerkiksi sijaita SPB:ssä, kun taas SPA isännöi tällä hetkellä hallintapalveluja. Tämä tilanne voi ilmetä SP:n uudelleenkäynnistyksen, vikasietotilan tai muun aktiivista SP:tä muuttavan tapahtuman jälkeen.

Ratkaisu

Käynnistä hallintapalveluita (tässä esimerkissä SPA) suorittava SP uudelleen, jotta päivitystiedostot sisältävästä SPB:stä tulee jälleen ensisijainen. Kun oikea SP on aktiivinen, Jatka- tai Yritä uudelleen -toiminnon pitäisi onnistua.

 

Huomautus: Ongelma on korjattu parantamalla Unity OE 4.3.x :ää ja uudempia versioita, mikä vähentää tallennussuorittimien välisistä hallintapalvelun vikasietoista johtuvien päivitysten jatkumisvirheiden todennäköisyyttä.

 

Jos ongelma jatkuu tämän toimenpiteen jälkeen, ota yhteys Dellin tekniseen tukeen ja lue tämä tietämyskannan artikkeli.

対象製品

Dell Unity 300, Dell EMC Unity 300F, Dell EMC Unity 350F, Dell EMC Unity XT 380, Dell EMC Unity XT 380F, Dell EMC Unity 400, Dell EMC Unity 400F, Dell EMC Unity 450F, Dell EMC Unity XT 480, Dell EMC Unity XT 480F, Dell EMC Unity 500 , Dell EMC Unity 500F, Dell EMC Unity 550F, Dell EMC Unity 600, Dell EMC Unity 600F, Dell EMC Unity XT 680, Dell EMC Unity XT 680F, Dell EMC Unity XT 880, Dell EMC Unity XT 880F, Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family, Dell EMC Unity Hybrid ...

製品

Dell Unity 300, Dell EMC Unity 300F, Dell EMC Unity 350F, Dell EMC Unity XT 380, Dell EMC Unity XT 380F, Dell EMC Unity 400, Dell EMC Unity 400F, Dell EMC Unity 450F, Dell EMC Unity XT 480, Dell EMC Unity XT 480F, Dell EMC Unity 500 , Dell EMC Unity 500F, Dell EMC Unity 550F, Dell EMC Unity 600, Dell EMC Unity 600F, Dell EMC Unity XT 680, Dell EMC Unity XT 680F, Dell EMC Unity XT 880, Dell EMC Unity XT 880F, Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family, Dell EMC Unity Hybrid ...
文書のプロパティ
文書番号: 000052735
文書の種類: Solution
最終更新: 15 7月 2026
バージョン:  7
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。