Dell Unity: keskeytettyä ohjelmistopäivitystä ei voi jatkaa tai yrittää uudelleen
概要: Dell Unity OE -päivitys ei välttämättä jatku keskeytyksen jälkeen, jos hallintapalvelut vaihtavat eri tallennussuorittimeen (SP) kuin siihen, jossa päivitystiedostot ovat. Käynnistä aktiivinen SP uudelleen niin, että päivityskuvan sisältävästä SP:stä tulee ensisijainen, ja yritä sitten päivitystä uudelleen tai jatka sitä. ...
現象
Unity OE -päivitys keskeytetään, koska Automatically Reboot Storage Processors -asetusta ei ollut valittu. Kun yrität jatkaa päivitystä, Unisphere-käyttöliittymä näyttää uudelleenlatausviestin, eikä päivitys jatku.
service@(none) spa:~$ uemcli -u admin -p xxxxx /sys/soft/upgrade resume Operation failed. Error code: 0x6000cb9 The system encountered an unexpected error while upgrading the software. Reboot your Primary storage processor and try upgrading again. Check System > Logs for related messages. (Error Code:0x6000cb9)
原因
Latausbinaarit ovat väärässä SP:ssä. Hallintapalvelut siirtyivät heti, kun päivitysnäköistiedosto ladattiin ja jatkamistoimintoa yritettiin.
解決方法
Tarkista /EMC/CEM/log/cemtracer.log tiedosto seuraavanlaisista merkinnöistä:
service@(none) spa:/EMC/CEM/log$ grep "papi_get.sh tasks_info" *log cemtracer.log:02 Aug 2017 23:03:36 - [UpdateProvider] FATAL - {0:x:x}[x|x|x][createJob @ ../../../components/providers/osls/UpdateProvider/src/C4CB_SoftwareInstallationService.cpp:1123] createJob exception: Failed to get tasks info: caused by the error in P-API backend (error running 'papi_get.sh tasks_info Unity-4.2.0.9392909.tgz.bin' meta (nil): request error code: 9, command error code: 0x100)
Tämä virhe ilmaisee, että päivitystä ei voi jatkaa, koska järjestelmä ei pysty hakemaan päivitystehtävän tietoja. Tavallisesti näin käy, kun päivitystiedostot sijaitsevat yhdessä SP:ssä, kun taas hallintapalvelut ovat käynnissä vertaispalvelussa. Päivitystiedostot voivat esimerkiksi sijaita SPB:ssä, kun taas SPA isännöi tällä hetkellä hallintapalveluja. Tämä tilanne voi ilmetä SP:n uudelleenkäynnistyksen, vikasietotilan tai muun aktiivista SP:tä muuttavan tapahtuman jälkeen.
Ratkaisu
Käynnistä hallintapalveluita (tässä esimerkissä SPA) suorittava SP uudelleen, jotta päivitystiedostot sisältävästä SPB:stä tulee jälleen ensisijainen. Kun oikea SP on aktiivinen, Jatka- tai Yritä uudelleen -toiminnon pitäisi onnistua.
Jos ongelma jatkuu tämän toimenpiteen jälkeen, ota yhteys Dellin tekniseen tukeen ja lue tämä tietämyskannan artikkeli.