Dell Unity: impossibile riprendere o riprovare un aggiornamento software sospeso
概要: Un aggiornamento di Dell Unity OE potrebbe non riprendere dopo essere stato sospeso se i servizi di gestione passano a uno storage processor (SP) diverso da quello che contiene i file di aggiornamento. Riavviare l'SP attivo in modo che l'SP contenente l'immagine di upgrade diventi primario, quindi riprovare o riprendere l'upgrade. ...
現象
L'aggiornamento di Unity OE è stato sospeso perché non è stata selezionata l'opzione Riavvia automaticamente gli storage processor. Quando si tenta di riprendere l'upgrade, l'interfaccia utente di Unisphere visualizza un messaggio Reload e l'upgrade non continua.
service@(none) spa:~$ uemcli -u admin -p xxxxx /sys/soft/upgrade resume Operation failed. Error code: 0x6000cb9 The system encountered an unexpected error while upgrading the software. Reboot your Primary storage processor and try upgrading again. Check System > Logs for related messages. (Error Code:0x6000cb9)
原因
I file binari di caricamento si trovano nell'SP errato. Si è verificato uno switchover dei servizi di gestione dal momento in cui è stato caricato "Upgrade image" e si è tentato di eseguire l'operazione "Resume".
解決方法
Esaminare /EMC/CEM/log/cemtracer.log File per voci simili a quelle riportate di seguito:
service@(none) spa:/EMC/CEM/log$ grep "papi_get.sh tasks_info" *log cemtracer.log:02 Aug 2017 23:03:36 - [UpdateProvider] FATAL - {0:x:x}[x|x|x][createJob @ ../../../components/providers/osls/UpdateProvider/src/C4CB_SoftwareInstallationService.cpp:1123] createJob exception: Failed to get tasks info: caused by the error in P-API backend (error running 'papi_get.sh tasks_info Unity-4.2.0.9392909.tgz.bin' meta (nil): request error code: 9, command error code: 0x100)
Questo errore indica che l'aggiornamento non può proseguire perché il sistema non è in grado di recuperare le informazioni sull'attività di aggiornamento. In genere, ciò si verifica quando i file di aggiornamento risiedono su un SP, mentre i servizi di gestione sono in esecuzione sull'SP peer. Ad esempio, i file di aggiornamento potrebbero trovarsi nell'SPB, mentre l'SPA ospita attualmente i servizi di gestione. Questa condizione può verificarsi dopo un riavvio dell'SP, un failover o un altro evento che modifica l'SP attivo.
Risoluzione
Riavviare l'SP che attualmente esegue i servizi di gestione (SPA in questo esempio) in modo che l'SP contenente i file di aggiornamento (SPB) diventi nuovamente primario. Una volta attivo l'SP corretto, l'operazione Resume o Retry dovrebbe avere esito positivo.
Se il problema persiste dopo aver eseguito questa azione, contattare il supporto tecnico Dell e fare riferimento a questo articolo della Knowledge Base.