AppSync:「移行スプーフィング」を有効にしてRDF Metro移行を使用すると、正しいアレイ上にAppSyncコピーが作成されない場合がある
概要: この記事では、移行スプーフィングが有効になっているRDF Metroの移行中に、AppSyncが移行済みアレイではなくソース アレイ上にコピーを作成する問題について説明します。
現象
RDF/Metroアレイの移行によってデータは移行されましたが、WWNスプーフィングはまだ実施されています。
RDF/Metro移行は、1つのアレイから新しいアレイにデータを移行するために使用されるツールです。
AppSyncは、新しいVMAXアレイのLUN番号を使用して、古いVMAXアレイにコピーを作成しようとします。
原因
ソースLUNに関する情報がSMI-Sから要求された場合、AppSyncリポジトリー内で新しいVMAXアレイのシリアル番号が更新されません。
ソース ホストの「inq.windowsamd64_exe -wwn」を使用して、ソースLUNのWWNを取得します。
この例では、WWNが表示されています。
D:\EMC Software>inq.windowsamd64_exe -wwn Inquiry utility, Version V8.4-2352 (Rev 0.3) built with SYMAPI Version V8.4.0.3 (Edit Level 2352) Copyright (c) [1997-2017] EMC Corporation. All Rights Reserved. For help type inq -h. ------------------------------------------------------------------------------ DEVICE :VEND :PROD :WWN ------------------------------------------------------------------------------- \\.\PHYSICALDRIVE17 :EMC :SYMMETRIX :60000970000196700xxx533030123456
次に、上記のWWNを使用して適切なアレイを取得するためにSMIS-Sがクエリーされます。
SMI-Sを手動でクエリーするには、次を使用できます。
- SMIS-SでTestSmiProviderを実行し、「ei」オプションを選択します
- クラスの入力を求められたら、「CIM_StorageVolume」と入力します。大文字と小文字が区別されます。
- Enterを押して、その他のプロンプトのすべてのデフォルトを使用します。
これは数時間実行される場合があります。出力は、TestSMIProvider を実行したフォルダーまたはディレクトリー内の TestSmiProvider.log ファイルにあります。出力を確認すると、「inq.windowsamd64_exe -wwn」から取得したWWNを含む長いエントリーが1つ見つかります。
読みやすくするために長いエントリの多くが削除されたため、次のようにリストされています。
Instance 5494: ObjectPath : Symm_StorageVolume.CreationClassName="Symm_StorageVolume",DeviceID="004FE",SystemCreationClassName="Symm_StorageSystem",SystemName="SYMMETRIX-+-000164200abc" <PROPERTY NAME="SystemName" CLASSORIGIN="CIM_LogicalDevice" PROPAGATED="true" TYPE="string"> <VALUE>SYMMETRIX-+-000164200abc</VALUE> <PROPERTY NAME="EMCWWN" CLASSORIGIN="EMC_StorageVolume" PROPAGATED="true" TYPE="string"> <VALUE>60000970000196700xxx533030123456</VALUE>
WWNのxxxは古いVMAXアレイに似ている場合がありますが、シリアル番号「000164200abc」は新しいVMAXアレイです。
原因は、AppSyncがこのシリアル番号を使用してAppSyncデータベースを更新していないため、AppSyncが「移行元」アレイにコピーを作成しようとするためです。
解決方法
AppSync 3.0.2のホットフィックスが存在します。このホットフィックスをリクエストするには、Dellカスタマー サポートにお問い合わせください。新しいサービス リクエストを作成する場合は、このナレッジベース記事IDをお知らせください。